Downloading on Apple Watch stuck at first song

Hey folks,


We're receiving reports that some users are unable to download music for offline listening on their Apple Watches. The download is stuck on the first song and doesn't progress.


If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.


We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 



Hello everyone,


We want to confirm, we're still investigating this. We're gathering your reports and passing them on.


Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.


When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.


As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.


Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection


We’ll get back to you again when we have new info. Thank you!







(iPhone 11 Pro)
Operating System

(iOS 14.7)
Spotify Version


My Question or Issue

I have selected the option to download to apple watch but the playlist remains at 1 of x downloading and nothing happens. I have tried re-installing the app. Turning the Bluetooth and WiFi on and off, restarting the phone and watch but the playlist will not download. They are on the same WiFi network. I have tried playing the playlist from my watch as I've seen other people say this started the download for them but the playlist is still not downloading


I had the same issue.

I've deactivated the passcode for the apple watch and rebooted the iphone an apple watch again.

Then the downloads started.

Doesnt work for me either.. Tried rebooting bluetooth connection.. Reinstalling app on warch..
Nothing works..
Stuck at 1 of x..

Surely you're not going to tell me this is normal? It's been stuck at downloading the first song for over 20 hours!


Same here and streaming does not work as well. White watch logo keeps flashing and keeps trying to connect endlessly... Hence, watch is still a simple remote.....


have had this issue all day, Spotify support has recommended many things, none worked. Tried the passcode fix also but no luck with that.


was able to be fixed on my end by playing the playlist I was trying to download from watch to AirPods while attempting to download it.


The fix (playing the playlist on the iWatch while  trying to download it) worked for me 🙂 of course after it was stuck on downloading for hours…


Hey folks,


Thanks for posting here 🙂


It's a good idea to check if there are any pending updates for both your phone and watch.


You can also try connecting your watch to a charger to start the download. Are there any changes?


Keep us in loop.


I am having the same issue. Is it necessary to be on WiFi for the downloads to begin? Can it not be done via cellular + Bluetooth? I have tried both but curious if WiFi is a baseline dependency. Thanks!