Downloading on Apple Watch stuck at first song

Hey folks,


We're receiving reports that some users are unable to download music for offline listening on their Apple Watches. The download is stuck on the first song and doesn't progress.


If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.


We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 



Hello everyone,


We want to confirm, we're still investigating this. We're gathering your reports and passing them on.


Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.


When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.


As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.


Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection


We’ll get back to you again when we have new info. Thank you!


Spotify, the comms to your customers is poor. This defect has been out there for a long period of time and the users are clearly frustrated with lack of progress, given competitor's processes work fine...


Any meaningful update with timelines please?



One disgruntled customer who will shortly be leaving




@jbfrancis3 I appreciate that you want to help, but turning bluetooth off on my iPhone and adding the playlist to Apple watch does not change anything for me. It still gets stuck at "1 of x...." forever for me. I have excellent wifi at home (google wifi mesh and 1tb network). I've tried several other wifi networks as well without any improvement. 



As I said a long time ago here, I tried everything and I mean everything! What worked for me was impairing and pairing back my watch. Worked first time and continues to watch and is a great feature. 


I will add: after bluetooth is turned off on the iphone, go back to the apple watch and force-quit Spotify app. On my watch, that's pressing down side button, swiping left on the Spotify "square" icon, and clicking red X. Go back and re-open Spotify app on the watch.


Things that seems to really help:

  • If your watch shows only dowloading the first song a gets stuck, kill your Spotify app on your watch: press the right button to show the active apps, get Spotify in front, swipe left and kill it by pressing the red cross. Restart Spotify on your watch and check the download process again.
  • Put your watch on a charger first and then start a download. Let it run for some 10 minutes, take the watch from the charger and inspect the download process.
  • Download the intended songs first to your phone and only then to your watch. 




I have tried all of the mentioned solutions and still no luck. Can’t get past the first song downloading state.


I have successfully gotten a playlist on my watch a couple months ago (another painful experience). I guess I just keep trying all of the mentioned solutions?


Its just disappointing that this feature still feels so buggy after all the time in development and slow rollout. 😔


I noticed that it starts to work for me if I download just 1 playlist at  a time. If I set multiple playlists to download at once it gets stuck at the "downloading" state on all of them. 


I’ve been having these problems since the release of this feature in may. 


Every time Spotify or Apple releases an update I’ve performed the following steps:

  • Restarted my watch
  • Force quitted the app
  • Performed a clean install of Spotify on both my phone and watch.
  • Unpaired/re-paired my watch with the Iphone


I’m a huge fan of Spotify but this is really frustrating. At least, please give us an update on what is happening.


So super frustrated with this. I specifically bough the apple watch to be able to listen to music while running without having to take my phone.

1) Spotify is extremely buggy and very often would just stop playing in the middle of my run. After a long while I found out that keeping the wifi switched off helped— apparently random public wifi triggers Spotify to get confused. Similarly if I forgot to set my watch to Do Not Disturb and I would get a call, Spotify would refuse to play afterwards. Extremely frustrating when you just got into the flow of your run.

2) When finally Download To Watch was released I thought I could finally be done with this**bleep**, but then it turned out that 90% of the time Spotify just plain refuses to download songs— god knows what it's bugging out over.

And sorry, but the "workarounds" are just dumb— who has time for that? Please just get**bleep** together and figure this out, Spotify. It's been a year!


They aren't dumb, they're the only option. What's dumb is you dismissing them, and further thinking that this will be addressed in the near-term. Spotify doesn't even acknowledge the problem. They continue to market the functionality like its a done deal.