Announcements

link error with Amazon Echo

Solved!

link error with Amazon Echo

Just set up Amazon Echo and upgraded Spotify to Premium.  All running well via Sonos.

However, Amazon and Echo will not link and just says "an error ocurred while attempting to link Alexa with external provider"

Any help happily accepted?

Thanks

Reply

Accepted Solutions
Marked as solution

I’ve resolved this now by using a PC (not Mac) and going through the linking process via http://layla.amazon.co.uk

Don’t know why, but this worked after the 2nd try.

View solution in original post

Marked as solution

None of the above solutions worked for me. UNlinked and re-linked through a variety of browsers tens of times. Did a lot of research online and the fix on this reddit post from Jay7962 was the only thing that worked: https://www.reddit.com/r/amazonecho/comments/5h9ptf/echo_dot_not_playing_spotify/

Basically, the problem seems to be with Spotify. Say 'Alexa Spotify Connect' and then she will tell you to choose the Echo Dot using Spotify Connect within the Spotify app. I then logged in on the desktop version and did exactly that. All working now!

View solution in original post

Marked as solution

hi had same problem you need to go to amazon -> your account --> digital content --> manage content and devices--> then youll see settings and you need to change the country to us 

View solution in original post

48 Replies

I am also having this issue.

I have a UK Echo which trying to connect to my Spotify family account.

This account has several users on it (not sure if related)

I see the same error.

I am also getting the same problem, unable to link my Spotify account with alexa

I am having exactly the same issue. UK accounts - works fine through Sonos

Fixed.

 

I was an early adopter to Spotify, not sure if this had something to do with it. HOpefully this helps someone else...

 

I logged into my Spotify profile online and went to look at my details. Two things:

1. My email was displaying as my username

2. My postcode was out of date (suspect this is a red herring)

 

I updated my email address to not be my Spotify username (user data migration gone awry at some point??) and actually be my email address and updated my password while I was there.

 

I went back into Alexa app and into the Spotify setup in there. I clicked on "not me" so as to start the linking process again and then logged in. I clicked OKAY and, for the first time ever, IT WORKED.

 

Hope this helps others

Marked as solution

I’ve resolved this now by using a PC (not Mac) and going through the linking process via http://layla.amazon.co.uk

Don’t know why, but this worked after the 2nd try.

Thanks all for your suggested solutions - much appreciated.

using the direct layla.amazon.co.uk instead of via app worked for me too

I also had this problem, doing it via the app and via Chrome on OSX was still causing issues.

 

To fix it I loaded up firefox, went to https://layla.amazon.co.uk, logged in, then Music & Books (rather than Settings) and linked from there.

 

Not sure if it was the fresh browser or the different link that fixed it, but at least it works 🙂

I tried via my iphone - didn't work.

Via Chrome on my mac - didn't work. 

Via Firefox on my mac - didn't work.

 

I then logged in to Spotify and noticed that Alex was one of the connected apps. I revoked access. I then went back in via Chrome to try again and it failed. Yet in Spotify, Alexa was there again as an app. I revoked access again and tried via Firefox. 

 

It worked that time! 

Marked as solution

None of the above solutions worked for me. UNlinked and re-linked through a variety of browsers tens of times. Did a lot of research online and the fix on this reddit post from Jay7962 was the only thing that worked: https://www.reddit.com/r/amazonecho/comments/5h9ptf/echo_dot_not_playing_spotify/

Basically, the problem seems to be with Spotify. Say 'Alexa Spotify Connect' and then she will tell you to choose the Echo Dot using Spotify Connect within the Spotify app. I then logged in on the desktop version and did exactly that. All working now!

Hay, I have a similar problem where Amazon Echo doesn't allow me to select Spotify as my music player. The option is there but is disabled and it doenst allow me to click. Frustrating...Anyone?
IMG_4005.PNG

check you amazon account settings i think 

i did, but there is nothing there mentioning echo ...

have the same problem outside uk and us

me too 😞 im live in france

Marked as solution

hi had same problem you need to go to amazon -> your account --> digital content --> manage content and devices--> then youll see settings and you need to change the country to us 

A-FUKIN-MAZING.

 

Days searching an answer with both Spotify and Amazon and no one capable of answering it. Thanks, just worked here!

It works now 👍🏻 Im live in France
Just create a new acount amazon.com with adress postal Us and connect your Amazon Echo with new login amazon.com and Enjoy 😅

IMG_2371.PNG

I still couldn't get it work. In Alexa Apps > Setting > Music & Media > Choose Default Music Service : The Default music library showed Amazon Music and Spotify. Unfortunately, I cannot select Spotify "Radio Button". It seem to be disabled from clicking on it.

 

Please help.

 

Singapore

Hi guys, never mind about my earlier post. I have managed to solve the problem.

 

The cause is, I don't know. This is what my situation is:

 

I bought this new echo dot and it is newly use with my amazon account using yahoo. I setup echo dot and everything works fine except the linking of spotify, pandora etc failed on me.

 

I was advice to reset the echo dot and try redo the whole setup all over but I add an additional procedure. I re-create my Alexa account with gmail account (which is also my Spotify Premium account), and login to try linking up my spotify. Surprisingly this time it works after Alexa apps and my Chrome explorer refresh the setting in less than 2-3 minutes after login out and login with my new created gmail account.

 

Now my echo dot could link and play all my loving music collection. There is nothing wrong to Spotify but the program in Amazon Echo Dot default setting could not establish firmly to pair our music source.

 

Thanks everyone for reading and hope this article helps all of you experiencing the problem.

 

Singapore

Suggested posts