Apple CarPlay Audio no longer working

Reply

Apple CarPlay Audio no longer working

Jamieip
Music Fan

Plan

Premium

Country

UK

Device

iPhone 7+

Operating System

iOS 12.2

 

My Question or Issue
My Spotify audio over carplay has entirely died now. Apple music works fine, siri works fine, all other apps work fine. However whenevever spotify gets to 2 secconds into a track the audio will suddenly die. I have tried everything I can to fix this. Assuming it was my phone, apple diagnosed it and said it is not an issue with the device. So I then assumed it was the car, (BMW/mini cooper S) of which after diagnostics they couldn't find the reason. Which both has led me to believe that this is issue is the app itself.

My last post got "closed" as I think it was in the incorrect group, however I cant seem to post in the group I was asked to post in. 


Thanks
Jamie

22 Replies

jrubesch
Newbie

I had the same problem with Samsung galaxy. The songs would play but no sound would come out. I opened Youtube to see if it was every audio/video. As soon as the Youtube video started playing, the music from Spotify played too. I just quit Youtube and the music on Spotify just continued normally.

EricRo
Newbie

I also have the exact same problem.  Spotify-Carplay-BMW X3

antoniopll
Newbie

I have the same problem. Please solve the problem Spotify!

mu-tron-kid
Casual Listener

It’s not just CarPlay, it is also any streaming to Apple Airport Express, Apple TV, etc.

This is from any iOS device that has the Spotify 8.5 update installed.

timpop
Casual Listener

So, there was a Spotify app update today for the iOS, but sadly this didn't solve my problem. Looks like Spotify is working on this here: https://community.spotify.com/t5/Ongoing-Issues/CarPlay-black-screen-no-controls-after-updating-to-i...

Jamieip
Music Fan

I spoke to my rep and he said they were expecting a fix “the last quarter” ( of the year) however no update from BMW OR Spotify corrected this issue. It is only BMW/mini that are affected as far as I am aware. I am not sure who is at fault. I am just angry that I bought a 35K+ car with the extra 4K for Apple carplay and also my Spotify subscription for it to not work. 

 

Give the reg to the rep and he will add it to the list of cars with this issue. Then once fixed should notify you. The more that report, the better 🙂 

joelthecoder
Casual Listener

It's not just BMW. It's something with Wireless Carplay. I have an aftermarket Panasonic avh-w4400nex and it stopped working too.

cullypokman
Casual Listener

Using Spotify on Wireless Carplay (Pioneer AVH-9150BT) - Audio track plays 2 seconds (there is sound) and after the sound will go off and track will still be playing.

It started after the recent Spotify Update 8.5.0.833 with Apple IOS 12.2 latest update last week.

 

Tried re-install spotify, reset HU, check all settings, has nothing to do with Waze or another other apps, nothing seems to work to fix playing but no sound issue.

 

All other audio apps works perfectly fine, only Spotify App has this problem. Now i am unable to use Spotify on my Wireless Carplay at all, which is a big problem. Hope Spotify team can urgently look into this issue. Thanks.

omegamanuk
Newbie

Hi,

 

I am the same, have a 2017 430d M Sport think its ID5/6 nav system and IOS 12.2 has broken carplay, went to www.bmw.co.uk/update and updated the Bluetooth to latest version, but this made no difference, interestly tried Napster App and music streamed fine, tried Apple Music and it streams but really glitchy when navigating through carplay menu to the point where you just give up and switch source to normal Radio FM etc!

 

Spotify issues, loads track shows that its playing but dont hear anything, you ether press back to replay the track and sometimes it plays music for 2 seconds then silence, you can also skip forward to play next track but does the same.

At the point where i am deciding to scrap both spotify and seek refund for the apple carplay which i purchased in Jan, intially worked fine  but with the constant updates from Apple and Spotify it seems like each party ends up breaking the service which just annoying! 

Other fixes i've tried, restoring my Iphone X to factory via itunes, and the reloading from backup! absoluting pain the back side! considering all security type apps need re autheticating it authenticators, bank apps the works, just isnt practical for end users to be having to do this everytime a **bleep** IOS or app update is performed.  Finally also removed and re added the phone to iDrive....no difference, therefore I can only assume that IOS 12.2 has broken something relating to Bluetooth between the car and phone, i say this because if you play the spotify app via the phone only and play a track, it works!  its just when connected to Apple Carplay the issue happens! Or the theres an issue with the app and apple carplay!!  I have no idea at the moment all i know is i have no reliable music in the car other than reverting to normal Radio or resort to transfering MP3 music to car!!

Ghoru
Casual Listener

Same issue here. 

Before the update I had issues when I opened Spotify, it would not play the track and I had to restart the track. But this was a minor inconvenience I could live with.

Since the last iOS update, however, the rest of the Carplay apps (music, podcast or navigation) work perfectly fine, except for the Spotify app. 1 or 2 seconds of music, then complete silence. And no workaround (I could find).

I did everything I could think off (unlink Waze and Spotify, connect through Bluetooth, connect through USB, removing Spotify app, resetting device, etc), but to no avail.

Since I'm spending 2+ hours in the car every day, this is becoming a point of severe annoyance. I'm seriously considering cancelling my membership and will give it until my next billing period before deciding.

Hope this is taken seriously soon.

Ghoru
Casual Listener

Update: After the Spotify update of 16th April 2019, I can use the app in the car again. It required me to remove the Spotify app from memory twice on my iPhone to eliminate the black screen issue, but afterwards it worked just fine!

Jamieip
Music Fan

As of the latest update Spotify now works very well, in terms of audio.

 

Thank you to everyone keeping this post relevant by commenting or liking to bring attention to the issue.

 

i have seen a few people state they’re having an issue with the black screen, however I am yet to encounter this. This may be due to previously reinstalling Spotify and unpairing/repairing my phone to car play. 

 

Also thank you to the devs working to fix this issue. I am currently sat in my drive, listening to my playlists with a smile 😊

 

i will update date if I do encounter further issues.

timpop
Casual Listener

Hi, problem solved for me as well. 

 

I updated my BMW i3 in-car system via some system upgrade via the menus in the car, waited 30+ minutes, and the next time I went for a ride it worked.

 

Thank god I didn't have to switch music service!

MattyT2686
Casual Listener

iphone 7 ios 12.2 latest spotify app (8.5.2.666)

pioneer sph130dab on the latest pioneer firmware revision 8.08

 

Still have the issue whereby you connect the iphone via cable for carplay and randomly between 5 minutes and half hour the auio cuts out. 

 

I have been unplugging the iphone and then re-plugging in to gain audio back.

 

Couple of things i have tried is turning on siri (ahaha) and under settings > touch id & passcode setting the USB accessories toggle to ON (green) which is actually dsabling the usb restriction on the phone (opposite to logic). This i am still testing but it seems doesnt make a difference.

 

Bluetooth seems to be okk but the whole point is to keep the iphone plugged into the stereo.

 

It does seem to be a spotify integration issue caused by apple updates

MattyT2686
Casual Listener

updqate on the problem.

 

issue was happening on bluetooth also. though i think this is an issue directly with the pioner headunit that i have.

 

i have also updated to ios 12.3 now and deleted the spotify app and re-installed. Hasnt really made the issue go away.

federico85
Visitor

Hello,

 

I am having the same issue you have described with CarPlay on my Abarth 595. The music plays for some time and then the audio cuts and then comes back again and then goes silent. It feels like when you are listening to the radio and then drive into a tunnel, with static and white noise as well.

 

I have tried to reset the Abarth unit to factory settings and it didn’t do it. Tried to update iOS but it was the same.

 

Bluetooth streaming/connection works fine so I can still listen to Spotify, but I want to do it with CarPlay!

Jamieip
Music Fan

I called up mini connect. They have had hundreds of complaints now. The tech said they were supposed to have it sorted last quarter but are still waiting on spotify as far as I am aware. This is well known.

 

Please call up mini connect, they will take down your Vehicle reg and add you to the growing list of people with this issue. You will be notified when a fix is released 🙂

timpop
Casual Listener

Im currently having the same issue. I think the last update broke CarPlay.

fire1022
Newbie

ditto, having the same problem. BMW Carplay, plays audio for a second and then nothing. HELP!

joelthecoder
Casual Listener

I'm experiencing the same issue on an after market unit (avh-w4400nex).

 

Music plays for 2 seconds and then the sound stops but my phone keeps on "playing"

SUGGESTED POSTS