Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Can't change the track using in car controls

Can't change the track using in car controls

Hey all,


I updated to the newest version of Spotify mobile app for iOS.

I connect my iPhone to the USB port in my Fiat 500 running Blue&Me

I have buttons on my steering wheel that normally allow me to skip back and forward to the next track, these are no longer working with Spotify.


Is anyone else having this issue?

44 Replies

As a follow up to this:


I've now made sure my in-car system is running the latest software. Still no luck.

Previously when plugged in it used to say "Accessory Connected" and only allowed interaction via the car controls, but now it only allows interaction by using the iPhone itself. To me it looks as if Spotify have changed the way this feature has been implemented and it is now no longer working with my car. This is obviously disappointing.


While I understand it's an unsupported product, I'm hoping this works again after a future update.



Same here. Sucks that Spotify doesn't support accessories very well.

Hey Sam,


I came up with a workaround solution. Try and retrieve the IPA file for the older version of the Spotify app (you might need to look into where you store your backups). I am now using this older version of my iPhone to allow it to work with my car stereo again.


Hope that helps!



Nice workaround. Will keep it in mind if it starts annoying me too much. Have you also had any problems with the next song not playing properly after one ends, or starting properly when you connect your phone.

Occasionally it does both those things - sometimes I might be because it is streaming and I'm in a poor signal area, other times it might be because the movement of the car has disloged the dock connection slightly.


It doesn't happen too often though.



Ah, happens to me even with local files, and no issues with the connections being loose either. Thanks anyway man.

Have had the same issue in both BMW and Infiniti vehicles. I can skip between tracks for a few times after connecting, then it simply stops working. Also, sometimes there's a delay of up to a minute or so between shifting the steering wheel control and the song actually changing.

I keep the app updated, there are no physical connection problems, and no internet issues (I'm running songs saved on my device, not streaming).

Spotify, please improve this situation to add support for proper functioning when connected to an auto's stereo system. Please don't say it's not possible due to the way the iPhone functions. We all know it is possible, since we have personally seen our mobile versions of Spotify work properly with our cars' audio systems, albeit for limited periods of time.

same issue here

One thing you might want to try is to ensure that the Music app is turned off from the Multitask menu on your phone. This might get things working again.
Airhorn Enthusiast

Already tried, didn't help. It always uses the ipad standard music app when I want to change the track on my steering wheel

Strange - I just tried using a Bluetooth device and using the controls on that device seemed to skip the tracks in Spotify... May I suggest a clean installation on your device? That might kickstart things into action.
Airhorn Enthusiast



I m not using BT but the build ipod usb interface. It shows title, artist etc. on the radio screen butwhen I use my steering wheel it skips to iTunes 

Hmm, I'm afraid we might be running out of suggestions here.


While we do our best to try and support and work with things like headsets and USB docks, we can't promise that everything will be compatible, as a lot of these things are generally set up to work with whatever the built in audio player is.


Saying that, a clean reinstallation might get things going. You can find instructions on how to that here

Airhorn Enthusiast

Reinstalled on my iPad, same problem

Same deal here - 2011 Subaru Legacy via USB. When I try and advance a track via steering wheel or head unit it switches to Music app. Pretty frustrating. I suspect it's an issue between my car stereo and iOS though, not necessarily a Spotify thing.

Completely agree with this.  It's likely something that iOS is doing since they're typically pretty restrictive with their APIs.

I've noticed problems with my new car and Spotify as well (car is a Mini).  I've noticed that forwarding tracks seems to work fine on Slacker.  I'll have to do some more testing - but I'd think if Slacker was able to make it happen then Spotify should be able to get it to work.

Good point. I'll give it a try with Track 8. If that works too we'll know that Spotify need to sort their sh*t out.

Unlike other users, my Spotify App (on iPhone 4S) seem to work / integreate perefctly with my BMW / Mini Cooper ipod connection.


I have been able to view current song title as well as use the back / forward buttons on my steering wheel.


All this has been working perfectly until (regretably) I downloaded the latest Spotify App update this evening (App:, Spotify Core: Now, I'm having the following problems:


- Song title does not display

- Steering controls no longer function

- Quick control (by duouble clicking the home button) no longer works, meaning I have to unlock my phone and control from App directly

- Worst of all, I can now no longer use my iPhone's own music!!!! as for some strange reason the car's integration can no longer see the iphone's local music!! only way to fix this is to delete the Spotify App from my iPhone, which then enables the car integration to restore itself.


Help please!!! I wish if there's anyway I can go back to the 2nd last vesrion of the Spotify iOS App!! 

Suggested posts