Problem trying to suscribe to Premium...

Solved!
Reply

Problem trying to suscribe to Premium...

Antonio_G_S_
Casual Listener

Hi,

 

I am trying to suscribe to Premium once more but when trying to pay, the system is continuosly charging but nothing more happens...

spoti.png

If I try to pay trough PayPal the system says I need do enable javascript which is already enabled and I can´t pay either... 😮

 

Thanks, in advance, for your help!

 

Antonio

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Merik
Community Legend

@Antonio_G_S_ wrote:

l unable... The page doesn´t charge:

 

 

And trying to re-do the other proccess and I get the same error... 😮


@Antonio_G_S_ That's definitely interesting. Can you try using a different web browser and/or network?

If your case is resolved, please click the 'Accept as Solution' button and add your kudos!

View solution in original post

Solution!

Merik
Community Legend

@Antonio_G_S_ wrote:

Tried with Firefox... Same happens!

 

BUT, I tried with Explorer and it worked! 🙂

 

Thank you very much! 


@Antonio_G_S_ That's good news! For some notes that I can bring to the team, what web browsers and versions were you using that it wasn't working on?

 

 

If your case is resolved, please click the 'Accept as Solution' button and add your kudos!

View solution in original post

7 Replies

Merik
Community Legend

Hey @Antonio_G_S_, welcome to the community!

 

What country are you located in and what country is listed on your account overview? Once I have that information, I'll provide some steps that should work.

If your case is resolved, please click the 'Accept as Solution' button and add your kudos!

Antonio_G_S_
Casual Listener

Wow, thanks for that quick reply! 🙂

 

I am located and listed in Spain. 

 

Thanks!

Merik
Community Legend

@Antonio_G_S_ wrote:

Wow, thanks for that quick reply! 🙂

 

I am located and listed in Spain. 

 

Thanks!


No problem! 🙂

 

First, clear your Internet browser's cache and cookies, then try subscribing by going to https://www.spotify.com/es/purchase/panel/?country=es#__main-pci-credit-card. Let me know how it goes!

If your case is resolved, please click the 'Accept as Solution' button and add your kudos!

Antonio_G_S_
Casual Listener

l unable... The page doesn´t charge:

 

spoti2.png

 

And trying to re-do the other proccess and I get the same error... 😮

Solution!

Merik
Community Legend

@Antonio_G_S_ wrote:

l unable... The page doesn´t charge:

 

 

And trying to re-do the other proccess and I get the same error... 😮


@Antonio_G_S_ That's definitely interesting. Can you try using a different web browser and/or network?

If your case is resolved, please click the 'Accept as Solution' button and add your kudos!

View solution in original post

Antonio_G_S_
Casual Listener

Tried with Firefox... Same happens!

 

BUT, I tried with Explorer and it worked! 🙂

 

Thank you very much! 

Solution!

Merik
Community Legend

@Antonio_G_S_ wrote:

Tried with Firefox... Same happens!

 

BUT, I tried with Explorer and it worked! 🙂

 

Thank you very much! 


@Antonio_G_S_ That's good news! For some notes that I can bring to the team, what web browsers and versions were you using that it wasn't working on?

 

 

If your case is resolved, please click the 'Accept as Solution' button and add your kudos!

View solution in original post

SUGGESTED POSTS