Automatically plays music when ulocking phone

Solved!
Reply

Automatically plays music when ulocking phone

Bilxthebroker
Music Fan

Hi,

 

Whenever I unlock my phone in the morning, Spotify suddenly starts playing a random song - I have tried everything to stop this but without success. It is infuriating!I am prepared to abandon Spotify altogether if this can't be fixed. Grateful for any advice please.

I am on a Premium account.

The device is a Samsung Galaxy G20 Plus, running the latest Android 10.

Thanks.

1 ACCEPTED SOLUTION
Solution!

vvinta
Casual Listener

AHHH I THINK I FIGURED OUT THE ISSUE! 

So whenever id unlock my phone in the morning it would instantly play music. 

I opened up Bixby earlier and it had a routine called "Good Morning "

Screenshot_20201004-175537_Bixby Routines.jpg

When you get to it, it has "spotify playlists"

The song in the pic is the one that played every single morning. You can just turn off the routine!

I hope this helped at least someone else 

Screenshot_20201004-175531_Bixby Routines.jpg

View solution in original post

18 Replies

Neo_Bahamut_19
Regular

My LG V30 has done this both times I was subscribed. It often does it when leaving a bluetooth device or Android Auto such as in my car. The next time I open up my phone the app starts blaring music for no good reason.

Bilxthebroker
Music Fan

I know, it drives you nuts! I saw a suggestion somewhere that it might be a Google Assistant problem, so I delinked Spotify from there, but it made no difference.

Mario
Moderator
Moderator

Hey @Bilxthebroker

 

Thanks for reaching out about this here in the Community.

 

Since it could be a temporary error, would you mind trying each of the following steps?

 

We'll look out for your reply and be here to help with anything else as well!

MarioModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"There's more to living than only surviving." - Dexter Holland

Bilxthebroker
Music Fan

Thanks Mario.

I have logged out and back in again. I am on V. 8.5.63.941 - is that the latest?

Mario
Moderator
Moderator

Hey @Bilxthebroker,

 

Thanks for keeping us in the loop.

 

Yes, V. 8.5.63.941 is the latest as of now 🙂 

 

Did logging out and than back in do the trick?

 

Keep us posted. We'll be here!

MarioModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"There's more to living than only surviving." - Dexter Holland

Bilxthebroker
Music Fan

Thanks Mario.

 

I don't know if this has worked yet because the problem only occurs on unlocking in the mornings! So please hold tight for a little while and I'll be sure to let you know.....thank you.

vvinta
Casual Listener
Did you ever find a fix? I read somewhere that Google Clock alarms are integrated with spotify. I wonder if that may be part of the issue

Peter
Moderator
Moderator

Hey there @vvinta and @Bilxthebroker,

 

Thank you for the reply.

 

As you mentioned @vvinta - it might have to do with the Google Clock alarms. If you have an active alarm and it occurs the same time every morning we suggest that you disable the integration to see if it changes. 

 

To turn off the integration, under the Spotify tab in Clock, you’ll see an ellipsis in the top right corner (3 dots). This will produce the settings overflow menu where you can install/uninstall Spotify as a media provider on Clock.

 

It would also be great if you can try to log in with a different account - for example a friend's or a family member's account to see if the issue persists.

 

If you haven't done a clean reinstall we suggest that you try that too. You'll find the steps here

 

Keep us posted. We're always one reply away.

 

Cheers!

PeterModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Bilxthebroker
Music Fan

Hi,

The problem continues, but I've just noticed another point. The apparently random songs are all played from a playlist called "Wake up happy". I haven't downloaded it and have no idea why it should play at all!

Alex
Moderator
Moderator

Hi @Bilxthebroker,

 

Thanks for your replies and the info.

 

Since you don't have Google clock enabled and you've performed a clean reinstall of the app, there are a few more things that could be causing this odd behavior.

 

If your account is connected to other smart devices like smart watches, smart speakers or home systems, this may be causing your phone app to play music if any daily routines are scheduled on those.

 

Could you try to Log out Everywhere. By doing this you'll log your account off any other devices, after that try logging in only on your phone for a day or two so that you can test if it continues to play music every morning. Don't worry you can log in on all of your devices again after this troubleshooting is done.

 

We appreciate your effort and understand that this might be inconvenient, however we need to rule out every possibility.

 

Keep us posted.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde
Solution!

vvinta
Casual Listener

AHHH I THINK I FIGURED OUT THE ISSUE! 

So whenever id unlock my phone in the morning it would instantly play music. 

I opened up Bixby earlier and it had a routine called "Good Morning "

Screenshot_20201004-175537_Bixby Routines.jpg

When you get to it, it has "spotify playlists"

The song in the pic is the one that played every single morning. You can just turn off the routine!

I hope this helped at least someone else 

Screenshot_20201004-175531_Bixby Routines.jpg

View solution in original post

Bilxthebroker
Music Fan

Nice one! I have never used Bixby but this routine was indeed turned on, along with the relevant Spotify playlist. I've turned it off and will wait and see what happens over the next few days....but I'm optimistic! Thank you!

Bilxthebroker
Music Fan

Thanks Peter.

 

I don't have a Google clock, so that isn't the issue. I have tried a clean app delete and re-load, and that doesn't work.

I will try logging in with someone else's account details and see if it makes any difference, but obviously can't run that test for long - the unwelcome start-up does not occur every morning.

Bilxthebroker
Music Fan

No, never. I've basically given up on it!

Mario
Moderator
Moderator

Hey @Bilxthebroker,

 

Thanks for your latest reply!

 

Sounds good. Keep us posted 🙂

MarioModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"There's more to living than only surviving." - Dexter Holland

Bilxthebroker
Music Fan

OK, so that didn't work. I have now uninstalled and reinstalled the app - will let you know if that works.

Bilxthebroker
Music Fan

Failed again. The bizarre thing is that it plays completely random songs that I would never listen to. This is just ridiculous (and often embarrassing!).

Bilxthebroker
Music Fan

Does anyone have any further thoughts on this, or are we all supposed to just accept that Spotify doesn't care? How hard can it be to fix this?

SUGGESTED POSTS