Announcements

Shuffle badge next to Play button always toggled on

Shuffle badge next to Play button always toggled on

Paulgi

Lately the horrendous Spotify application on android plays all albums and playlists in shuffle mode by default (which should even be illegal). I never ever listen to any album on random, it doesn't make any sense. But someone on Spotify decided to change the themes order on all albums ever made. Maybe it's a joke but it's taking too long to end.  I know that I can always disable it after starting to play the first music, but I want the inverse, I want to disable that annoying thing from default. I already checked the settings but I didn't figure out how to fix this stupidity.

 

Plan

Premium

Country

 

Device

Sony Xperia 5 II

Operating System

Android

 

My Question or Issue

 

Reply
47 Replies

stianschjelderu

I have the same problem. Premium/family user. Android and desktop both plays all playlists (even podcasts with subsequent episodes) automatically on shuffle. The buttons seems to have disappeared from the general interface and is nowhere to be found in the settings either. PLEASE FIX (currently listening to a 56 episodes podcast...)

 

S

MafeG

Hi folks,

 

Thank you for reaching out to the Community.

 

@Paulgi To start playing any playlist or album in order, simply open it and tap the first song (making sure the Shuffle button is already off). By tapping on the big green play button it'll automatically do it on shuffle.  

 

Other users have suggested the implementation of having both Play and Shuffle buttons. You can support the idea by leaving your +Vote.

 

@stianschjelderu What you mention sounds slightly different to the original issue. Could you share with us some screenshots or a video recording showing what you see on your end? 

 

Also, is this happening across all playlists and albums, or only certain sections? 

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

stianschjelderu

Hey!

 

All my platforms (Android, car, laptop and stationary PC) seems to be "back on track". Please see attachments from a couple of days ago, missing the random play button (same on all platforms), and today. Bug fixed?

Thanks for the reply, regards/ Stian Schjelderup

stianschjelderu

Attachments

 

Spotify today.JPG
Spotify 1.JPG

OscarDC

Hey @stianschjelderu,

Thank you for keeping us in the loop and for the screenshots you’ve shared.

 

It's expected for the Shuffle button to disappear when listening to a podcast. This is because the button is replaced for different ones to change the speed and to go 15 seconds forward/backwards. For some users, this Shuffle play button also gets replaced for the regular play button when selecting an album.

Keep in mind that Premium subscribers can deactivate the shuffle listening from the now playing view by hitting the Shuffle button.

Hope this helps. If you have any additional questions, the Community will be here to help.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

JENSER_

I have the same issue as OP.

 

Whenever I open a Playlist. The shuffle toggle next to the Play button is enabled - making the Playlist play with shuffle on when click on any song. If I disable the shuffle by clicking on it (in the Playlist view - not the play view), the shuffle toggle is still enabled whenever I go in to another Playlist or go back to the previous Playlist. If this is on purpose (and not a bug) I suggest Spotify allows us to set default playing option in settings (Start every Playlist on shuffle on/off..

OscarDC

Hey @JENSER_,

 

Thank you for reaching out to the Community.

 

The issue you're mentioning is quite different from the one in the original post. To have a better look at the issue, would you mind attaching a screenshot where we can see the shuffle toggle next to the Play button in the playlist view? 

 

We'll be on the lookout for your next response. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Jak7874

 

Plan

Premium

Country

United Kingdom

Device

Google pixel 6

Operating System

Android 12

 

My Question or Issue

All of my playlists are set to automatically shuffle. 

 

If I open a playlist, the shuffle option is enabled. This is happening on all of my playlists. 

 

I am not referring to the "shuffle play" option. If I tap the first song to start the playlist it shuffles everything. If I disable the shuffle play, next time I open the playlist it will be enabled again.

 

I am a premium member, and this is only happening on my phone, not my tablet. 

 

I'm not sure why this is happening, or how to disable it. It is driving me crazy. 

Screenshot_20220221-193719.png

OlleOlsson

I have the same problem and it is very annoying! Been searching on how to disable it but do not find anything. All artist most played songs are on shuffle by default. If I click on the button they are not on shuffle next time though... this started perhaps a week ago? As said, very annoying since I do not want to shuffle songs...

Eni

Hey @JENSER_@Jak7874@OlleOlsson,

 

Thanks for all the info you've sent so far.

 

We’re always testing possible improvements and new features, so you might see something on the app that other users don't, or get a brand-new feature for only a temporary period.

 

We appreciate you taking the time to share your feedback with us and will make sure to pass it onto the right team, as we always strive to improve your experience.

 

As a workaround, we suggest playing the first song in the album > going to the Now playing view and making sure the Shuffle option is disabled in there.

 

On another note, would you mind sending us a screen recording where we can see the issue happening so we can take a closer look?  You can attach it to your next response by using the Insert Video option in the post editor or upload it to a different platform and send us the link to it. 

 

We'll be on the lookout for your replies.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Thisisnatalie

My husband doesn't have the autoshuffle play button even tho we have same phone and Spotify version. Maybe they're doing A/B testing? Can't find a setting to change it. 

Screenshot_20220228-180034.png

Elena

Hi there @Thisisnatalie,

 

Thank you for joining the thread!

 

This is indeed a test and some users get 2 separate buttons on their playlist view, for others the option to have the Play button with no Shuffle is currently available for albums only.


Hope you found this information helpful.
Let us know if any further questions arise.

Many thanks!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Domanas

Is it possible to turn of automatic shuffle? Every time I turn on app on phone its on. All good on desktop.

bosi

When will this bug be fixed? It is a bad bug to set shuffle to ON by default.

Fed6

If this is a test how long will it last? I always played songs in my playlists by tapping the first song (or any song in a playlist) and it would then just follow the order of the playlist. Today it just shuffles everything unless I press the green shuffle button to turn it off. I think it makes more sense to make shuffling an option, as opposed to making not shuffling one. Is there a way to turn it off or do we just have to wait it out (until hopefully the whole community says this is a terrible idea)? Thanks

Yordan

Hi @Domanas,

 

Thanks for reaching out to the Community.

 

Could you let us know the following:

  • your phone's make, model and OS version
  • the version of your Spotify app
  • the troubleshooting steps you've tried so far

If you haven't already, try clearing the app's cache to see if that does the trick. You can do that in the app's Settings > Storage > Clear Cache. Your downloads won't be affected, so don't worry.

 

Keep us posted.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Domanas

Sorry, let me clear myself. I can turn off shuffle, but it's on by default every time I turn on app.

pixel 6

android 12

spotify v.8.7.10.1262 

Jeremy

Hi there @bosi,

 

Thank you for your reply and feedback in this thread.

 

We understand that things can feel frustrating when things don't work as you'd like them to. Rest assured that we're always trying to improve as we always strive to improve our features.

 

For now we suggest that you follow the steps that @MafeG provided in the reply above.

 

We hope for your understanding and that you continue using Spotify and find it gets better in the future.

 

Once again - thanks for the feedback, we appreciate it. Let us know if we can help you with anything else. 

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

bosi

If you do understand, why don't know you fix the bug, now, please. I don't want your understanding, I want you to fix the bug.

We already know how to get around this bug.

And it should be evident that this is a newly introduced bug, so why do you ask me which version of spotify I use?

Can you please fix the bug immediately. And make sure these kinds of bugs do not pass your regression in the future. There are too many of them.

Suggested posts

Env: prod