Announcements
Current information of our Google Nest Mini Offer can be found here.

Spotify Not Showing On Android Auto

Solved!
Reply

Spotify Not Showing On Android Auto

Regular

Plan: Premium

Country: USA

Device: Samsung Galaxy S10

Operating System: Android 9

 

Spotify doesn't show up in the Android Auto Menu. 

This symptom was covered in another thread from a few years ago but it seems something else is going on. 

 

  • Have uninstalled both Spotify and Android Auto and reinstalled both.
  • Have restarted phone.
  • Have checked "Device Broadcast Status" in Spotify Settings.

 

Where's Spotify?Where's Spotify?Version 8.5.9.737Version 8.5.9.737Device Broadcast StatusDevice Broadcast Status

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: Spotify Not Showing On Android Auto

Casual Listener
  1. Launch the Android Auto app.  
  2. Tap the top left menu and select About.
  3. Tap About Android Auto 10 times to unlock Developer Mode. Select top right menu and check if there's Developer settings
  4. Select Developer settings and scroll down to Unknown sources

try this as it worked for me, ensure you close/force close all apps and re open it. 

View solution in original post

21 Replies
Highlighted

Re: Spotify Not Showing On Android Auto

Casual Listener

I'm also having this issue after restoring my Note 9. if I play Spotify before I plug it in Spotify continues to play through my car but I have no control over it. 

Highlighted

Re: Spotify Not Showing On Android Auto

Regular

I was on chat with Spotify and they ask you to go through the usual things, like clear the cache, etc.  Nothing worked, and after an hour plus they now acknowledge it's a bug in their app affecting Android 9.

 

It's very disappointing, it's like they don't test AA at all.  This would be the very first thing they'd see. 

Highlighted
Solution!

Re: Spotify Not Showing On Android Auto

Casual Listener
  1. Launch the Android Auto app.  
  2. Tap the top left menu and select About.
  3. Tap About Android Auto 10 times to unlock Developer Mode. Select top right menu and check if there's Developer settings
  4. Select Developer settings and scroll down to Unknown sources

try this as it worked for me, ensure you close/force close all apps and re open it. 

View solution in original post

Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

This worked for me. Thanks!

Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

This worked for me. I'm using a Galaxy S10. 

 

Thanks!

Highlighted

Re: Spotify Not Showing On Android Auto

Roadie

Thank you ....

Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

Worked for me... Moto X4 (version 9, android one)!

Highlighted

Re: Spotify Not Showing On Android Auto

user-removed
Not applicable

Thank you so much! I nearly returned my S10 and got an iPhone just for the CarPlay feature. (Dumb, I know, but I drive a ton!) 🙂

Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

I do not see the Developer settings in mine. Am I missing something? Galaxy S9+ is my phone.

SUGGESTED POSTS