Announcements

Spotify Not Showing On Android Auto

Solved!

Spotify Not Showing On Android Auto

Plan: Premium

Country: USA

Device: Samsung Galaxy S10

Operating System: Android 9

 

Spotify doesn't show up in the Android Auto Menu. 

This symptom was covered in another thread from a few years ago but it seems something else is going on. 

 

  • Have uninstalled both Spotify and Android Auto and reinstalled both.
  • Have restarted phone.
  • Have checked "Device Broadcast Status" in Spotify Settings.

 

Where's Spotify?Where's Spotify?Version 8.5.9.737Version 8.5.9.737Device Broadcast StatusDevice Broadcast Status

 

Reply
Top Answer
AlBou1977
Casual Listener

Personnally, using Dev options doesn't work.  By the way, I've find another solution : 

Open your settings and go to Manage apps.  Then in Spotify, there's an Autostart option where you can find "Allow the app to be started by other apps"

This solved my problem.  Hope it can help some of you 😉


Accepted Solutions
Marked as solution

  1. Launch the Android Auto app.  
  2. Tap the top left menu and select About.
  3. Tap About Android Auto 10 times to unlock Developer Mode. Select top right menu and check if there's Developer settings
  4. Select Developer settings and scroll down to Unknown sources

try this as it worked for me, ensure you close/force close all apps and re open it. 

View solution in original post

22 Replies

I'm also having this issue after restoring my Note 9. if I play Spotify before I plug it in Spotify continues to play through my car but I have no control over it. 

I was on chat with Spotify and they ask you to go through the usual things, like clear the cache, etc.  Nothing worked, and after an hour plus they now acknowledge it's a bug in their app affecting Android 9.

 

It's very disappointing, it's like they don't test AA at all.  This would be the very first thing they'd see. 

Marked as solution

  1. Launch the Android Auto app.  
  2. Tap the top left menu and select About.
  3. Tap About Android Auto 10 times to unlock Developer Mode. Select top right menu and check if there's Developer settings
  4. Select Developer settings and scroll down to Unknown sources

try this as it worked for me, ensure you close/force close all apps and re open it. 

This worked for me. Thanks!

This worked for me. I'm using a Galaxy S10. 

 

Thanks!

Thank you ....

Worked for me... Moto X4 (version 9, android one)!

Thank you so much! I nearly returned my S10 and got an iPhone just for the CarPlay feature. (Dumb, I know, but I drive a ton!) 🙂

I do not see the Developer settings in mine. Am I missing something? Galaxy S9+ is my phone.

Click the menu button on the top left. Then click About. Once in the about section you should see three vertical dots next to the settings icon. Click on the dots, and you should see developer settings listed. See screenshot attached. Let me know if you're still having issues.

Screenshot_20190627-115926_Android Auto.jpg

This fix didn't work for me but I found a thread and the fix for me was to:

 

1. Run AA

2. Go to "Settings"

3. Scroll down and hit "Version" several times until you get comfirmation that "Developer settings" is enabled.

4. Choose "Unknown sources". 

5. Close open apps and restart. 

It worked on my Sony Xperia XZ2.

Thanks, it helped to resolve on my Galaxy S8+

Tapping Version in the Settings menu seems to be the new way to do this or at least an alternate path to try if the other solutions offered don't work for you.  Worked for me using a Xiaomi Redmi Note 7.  Restarting both Android Auto and Spotify (if it was running when you made the change) was key for me to get it to work.

Tap on version until it prompts developer access. Then tap the three dots in the top right. Developer menu, check unknown sources. Worked on my s10

Screenshot_20190719-194704_Android Auto.jpg

Hi,

 

I have enabled the developer mode , and ticked the unknown source box without any (direct) results.

 

My solution is first start Spotify and after that start Android auto. 

 

I struggled with this issue every time I used android auto , since I tried this "combination" the problem for me and my Poco f1 has been solved.

Personnally, using Dev options doesn't work.  By the way, I've find another solution : 

Open your settings and go to Manage apps.  Then in Spotify, there's an Autostart option where you can find "Allow the app to be started by other apps"

This solved my problem.  Hope it can help some of you 😉

>>"Then in Spotify, there's an Autostart option where you can find "Allow the app to be started by other apps"<< - this chapter helpes me, not any dev mods and other, just simply start by other app works fine. Btw thank U 😉

Great! Thanks!

Worked on my Samsung Note 8

Suggested posts