Announcements
Current information of our Google Nest Mini Offer can be found here.

Spotify Not Showing On Android Auto

Solved!
Reply
Highlighted

Re: Spotify Not Showing On Android Auto

user-removed
Not applicable

Click the menu button on the top left. Then click About. Once in the about section you should see three vertical dots next to the settings icon. Click on the dots, and you should see developer settings listed. See screenshot attached. Let me know if you're still having issues.

Screenshot_20190627-115926_Android Auto.jpg
Highlighted

Re: Spotify Not Showing On Android Auto

Visitor

This fix didn't work for me but I found a thread and the fix for me was to:

 

1. Run AA

2. Go to "Settings"

3. Scroll down and hit "Version" several times until you get comfirmation that "Developer settings" is enabled.

4. Choose "Unknown sources". 

5. Close open apps and restart. 

Highlighted

Re: Spotify Not Showing On Android Auto

Visitor

It worked on my Sony Xperia XZ2.

Highlighted

Re: Spotify Not Showing On Android Auto

Visitor

Thanks, it helped to resolve on my Galaxy S8+

Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

Tapping Version in the Settings menu seems to be the new way to do this or at least an alternate path to try if the other solutions offered don't work for you.  Worked for me using a Xiaomi Redmi Note 7.  Restarting both Android Auto and Spotify (if it was running when you made the change) was key for me to get it to work.

Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

Tap on version until it prompts developer access. Then tap the three dots in the top right. Developer menu, check unknown sources. Worked on my s10

Screenshot_20190719-194704_Android Auto.jpg
Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

Hi,

 

I have enabled the developer mode , and ticked the unknown source box without any (direct) results.

 

My solution is first start Spotify and after that start Android auto. 

 

I struggled with this issue every time I used android auto , since I tried this "combination" the problem for me and my Poco f1 has been solved.

Highlighted

Re: Spotify Not Showing On Android Auto

Casual Listener

Personnally, using Dev options doesn't work.  By the way, I've find another solution : 

Open your settings and go to Manage apps.  Then in Spotify, there's an Autostart option where you can find "Allow the app to be started by other apps"

This solved my problem.  Hope it can help some of you 😉

Highlighted

Re: Spotify Not Showing On Android Auto

Newbie

>>"Then in Spotify, there's an Autostart option where you can find "Allow the app to be started by other apps"<< - this chapter helpes me, not any dev mods and other, just simply start by other app works fine. Btw thank U 😉

Highlighted

Re: Spotify Not Showing On Android Auto

Visitor

Great! Thanks!

Worked on my Samsung Note 8

SUGGESTED POSTS