Announcements

Spotify controls no longer showing on lock screen

Solved!

Spotify controls no longer showing on lock screen

FortressButress

On my lock screen, the Spotify controls no longer appear as a permanent notification while music is playing. They are still present when I expand the notification bar on an unlocked phone, however.

I have tried closing and reopening the app, logging out and in, and also uninstall/reinstall.

All Spotify notifications are enabled in-app and in Android settings both (Settings > Lock Screen > Notifications) and  (Settings > Apps > Spotify > Notifications).

Attached image is what I see when I expand the notification bar while music is paused, and what I would expect to see on the lock screen.

 

I suspect this has something to do with a recent Android update which changed Samsung's "OneUI."

Info:

Samsung Galaxy S20FE 5G

OneUI version 4

Android version 12

Spotify app version 8.7.4.1056

 

Screenshot_20220215-182025_Spotify.jpg
Reply
Top Answer
Jordanb95
Newbie

I've been having a lot of troubles wjth this too after updating my Phone (S10 5G) and started going through every possible setting to find out what to do ti fix it. Everything on this current thread had no help so I went back to looking.

 

I decided to go into the; SETTINGS - APPS - SPOTIFY - NOTIFICATIONS - NOTIFICATION CATEGORIES - PLAYBACK(Turn on this setting) 

My playback setting was somehow off, I turned it on, started playing music and then started receiving the controls at the top of my regular notifications bar, and the controls on the lock screen too.

I hope this works for the rest of you. 🙂 


Accepted Solutions
Marked as solution

FortressButress

The feature you describe was on by default when I checked. I turned it off and restarted, then tried playing music to verify (no controls present on lock screen). Then I turned it back on and restarted the phone with the same result.

However, I noticed when I swiped on my lock screen in a different way, the voice recorder widget appeared (which was a separate issue or so I thought because it kept doing this randomly). From there I went into the Lock Screen > Widgets menu, and turned ON the "Music" widget. Previously I had assumed that this was for Samsung's internal music player app only, which could be why it was turned off. It also may have been turned off by default upon upgrading to Android 12.

Turning on this widget allowed the Spotify widget/notification with playback controls to appear on the lock screen when music is playing, and for a short time after pausing a track. I am not sure if this is correct functionality (which is why I am hesitant to mark this as a solution), but it seems to at least be a workaround for my issue.

View solution in original post

Marked as solution

ShuaShak

I experienced this problem after a recent update. I found that my notifications were turned off for Spotify. I solved the problem by going to Settings - Apps - Spotify - Notifications and then toggled Show notifications to on. I also selected delivery quietly. Perhaps having notifications turned off was preventing the music widget from appearing on the Lock Screen. This fixed it immediately. 

View solution in original post

27 Replies

Novy

Hey @FortressButress,

 

Thank you for reaching out to the Community and welcome.

 

We understand you’ve already tried some troubleshooting steps including reinstalling. However, we’d like to suggest a clean reinstall as this is more thorough than a regular one and can be helpful to get rid of any cache that might be causing trouble.

 

If the issue persists, could you record a short video where we can take a better look? You can attach it to your next response by using the Insert Video option in the post editor. This will help us investigate further.

 

We'll be on the lookout for your next response.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

FortressButress

Video is attached to the OP. Note that screen recordings are not possible due to the phone being locked (screen recorder automatically stops recording when phone is locked). The video was also taken *after* a clean reinstall.

 

The video is low quality, but should get the point across. You can see me play a song on Spotify, open the notification bar to see that the song is playing and has the controls, then I lock the phone. When I turn the screen on, observe no Spotify notification and no playback controls.

MafeG

Hi @FortressButress,

 

Thank you for keeping in touch. 

 

There are other things we can check here. When Spotify is playing, swipe down from the top when your phone is unlocked > Swipe down again on the Spotify media controls and tap on Media Output > Press 3 dots in the top right > Settings > Make sure "Use while the phone is locked" is toggled on.

 

After this, restart your phone and check if the media controls show up.

 

Let us know how this goes.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

FortressButress

The feature you describe was on by default when I checked. I turned it off and restarted, then tried playing music to verify (no controls present on lock screen). Then I turned it back on and restarted the phone with the same result.

However, I noticed when I swiped on my lock screen in a different way, the voice recorder widget appeared (which was a separate issue or so I thought because it kept doing this randomly). From there I went into the Lock Screen > Widgets menu, and turned ON the "Music" widget. Previously I had assumed that this was for Samsung's internal music player app only, which could be why it was turned off. It also may have been turned off by default upon upgrading to Android 12.

Turning on this widget allowed the Spotify widget/notification with playback controls to appear on the lock screen when music is playing, and for a short time after pausing a track. I am not sure if this is correct functionality (which is why I am hesitant to mark this as a solution), but it seems to at least be a workaround for my issue.

FPG79
  • Hello, I've been facing the same issue (controls no longer showing on lock screen) for a few days on my Galaxy Note 10+. Seems Indeed linked to Samsung update (similar issue happened with a podcast reader).

Tried the above proposed solution, but I don't see the Spotify media control on my unlocked phone (cf "swipe down from the top when your phone is unlocked > Swipe down again on the Spotify media controls and tap on Media Output")

 

OscarDC

Hey @FortressButress,

Thank you for keeping us in the loop.

 

We appreciate the time you took following the troubleshooting steps and for sharing that temporary solution.

On our side, we’ve tried to reproduce the issue, but it was not possible. 
However, we'll keep an eye on new reports to check if the OS update could be involved.

If you have any additional questions, the Community will be here to help. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

ckasabula

I had the same issue (no Spotify on lock screen) on LG G8 Thinkq after upgrading to Android 11. Took a while but figured it out. Solution:

Settings -> Lock screen & security -> Lock Screen

Style: Show content

2022-03-19 19.19.28.png

Rachellove

I'm having the exact same issue post-update. Everything the same except that I did have the Music widget "on". None of these workarounds have worked for me yet. Have restarted the phone and tried going through Spotify directly. Followed all troubleshooting I could find about lockscreen displays - no luck so far!

OscarDC

Hey @Rachellove,

 

Thank you for keeping us in the loop.

 

We appreciate the troubleshooting you've done so far, but to be sure that we're on the same page - did you use these steps for a clean reinstall? They are more thorough than a regular one. That way you can make sure the cache is not causing this issue.


If the issue persists, would you mind turning the Music widget option off, restarting your phone and turning it on again to see if it makes any difference? This will help us have a better look at the issue.

 

We'll be waiting for your next response. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

UpSticks

Solution that worked for me: settings > lock screen > notifications and then set it to 'details' instead of 'icon only'

Jordanb95

I've been having a lot of troubles wjth this too after updating my Phone (S10 5G) and started going through every possible setting to find out what to do ti fix it. Everything on this current thread had no help so I went back to looking.

 

I decided to go into the; SETTINGS - APPS - SPOTIFY - NOTIFICATIONS - NOTIFICATION CATEGORIES - PLAYBACK(Turn on this setting) 

My playback setting was somehow off, I turned it on, started playing music and then started receiving the controls at the top of my regular notifications bar, and the controls on the lock screen too.

I hope this works for the rest of you. 🙂 

vranascody

Did not work for my Samsung galaxy s10+. Using spotify version 8.7.22.1125. 

 

Widget was already activated, turned on and off, still no player. 

corakeen

there is no "use while phone locked or whatever.  is that in spotify settings or in android seetings?  could you provide screen shots please?

 

Maariatoup

Hello, I have the same problem since Android updated v12. No longer Spotify control bar showed  when screen locked. It doesn't appear either when the phone Samsung S21 isn't lock. And I can't even pause the audio, Spotify doesn't show what's playing even inside Spotify. 

None of the tips above work. What's wrong?

Jeremy

Hi there @folks,

 

Thank you for your replies in this thread.

 

@vranascody and @corakeen - can you let us know what troubleshooting you've done so far so that we can help you out in the best way without repeating anything that you've already done.

 

@Maariatoup - it seems like you're referring to this ongoing issue when it comes to the now playing bar missing, We recommend that you head over there and leave a +VOTE and Subscribe to the thread for any updates regarding this.

 

On another note, can you all let us know which Spotify version you're having?

It would also be great if you can check if you have any pending OS updates.

 

We'll keep an eye out for your replies.

 

Have a great continued day!
 
 
 

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Evisma

Finally got it to work on Samsung Galaxy S20+.

Settings>Apps>Spotify......

Allow all notifications. 

I had this off forever because I don't need to know every time U2 or Five Finger Death Punch drop another musical cr@p on our plates. 

I now have my lockscreen widget back.

mickp99
This is exactly what was needed. Thank you very much Jordanb95.
YOU HAVE SOLVED IT.
To all others,I would recommend you work through Jordan's recomendation methodically. I fixed my Nokia 4.2, Samsung tablet and also N5.1 All had Android and Spotify lock screen controls are working properly. NOTE: I have only the 'Playback' item ticked. All other Spotify promo rubbish in the list is not needed on my lock ecreen. Cool.

Thanks again Jordan.

Jeremy

Hi there folks,

 

Thank you for your replies in this thread.

 

We're super glad to see that everything works as it should for you and it's also very nice of you to share your solutions with the rest of the Community.

 

Have a great continued weekend 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

lewa999

Thanks! This solved my issue. So you need to go to Settings > Apps > Spotify > Notification > Allow Notification then ensure Spotify toggle is on. 

Suggested posts

Env: prod