Low Frame Rate with Desktop App

Solved!
Reply

Low Frame Rate with Desktop App

tshum
Regular

Plan

Premium

Country

Canada

Device

Desktop

Operating System

Windows 10

 

My Question or Issue

Recently I've done a clean uninstall of Spotify because it was taking up a large amount of space on my drive and then reinstalled it. Since then, I've been getting low frame rates with the Spotify App when focusing on the App (I know it's a minor inconvenience but I do notice it when I switch between windows). I have tried doing a clean uninstall, but nothing has changed. The Spotify App works smoothly on my laptop, which just had Spotify installed on it, so I am unsure what the cause of this is.

 

1 ACCEPTED SOLUTION
Solution!

bagool64
Newbie

I found a fix!

 

In NVIDIA Control Panel, go to "Manage 3D Settings" near the top of the left window, click the "Program Settings" tab, then add "Spotify.exe" to the list of programs. It's located in "C:\Users\*name*\AppData\Roaming\Spotify". Once you do that, go to the setting called "Monitor Technology" and change it to "Fixed Refresh." After this, the desktop app should run smoothly like it did before.

View solution in original post

Bg3Zkkb.png
24 Replies

monogordo
Newbie

Wild. I have had my new monitors for about a week with gsync on both (240hz, 2080TI, 2x Acer Predators). App started killing the frames on the monitor it would appear on just today. Wild how one music app will murder a gaming rig lol. The "3D Settings" fix action was 100% spot on tho. Good look. 

MiNiMaLiZz
Casual Listener

 Disabling hardware acceleration from spotify also fixed the problem for me, you should try that out too

Eds89
Music Fan

And for me!

 

This a Spotify problem or driver problem? I feel Spotify problem. Spotify please fix?

SynysterNght
Casual Listener

I noticed that Norton does have the same problem in the program

Solution!

bagool64
Newbie

I found a fix!

 

In NVIDIA Control Panel, go to "Manage 3D Settings" near the top of the left window, click the "Program Settings" tab, then add "Spotify.exe" to the list of programs. It's located in "C:\Users\*name*\AppData\Roaming\Spotify". Once you do that, go to the setting called "Monitor Technology" and change it to "Fixed Refresh." After this, the desktop app should run smoothly like it did before.

View solution in original post

Bg3Zkkb.png

100thz
Newbie

you are a genius

CruiseTheBlues
Visitor

To add to this, I had to also change the "Preferred refresh rate" setting to "Highest available", and it worked like a charm.

PauuloBorges
Newbie

Thx man, this works fine for me.

Mitich
Newbie

Thank You Bro You Are A Master!!!

0mega4711
Newbie

The better fix is to set the "preferred refresh rate" to "highest available" instead of application controlled. This fixes the problem without affecting other applications using G-Sync.

corb06
Newbie

Thanks! This solved my problem with low framerate

plasmabubble
Newbie

Fantastic! Thanks, friend.

 

Note: for me, I added the "spotify music" application near the top of the auto-generated list that Nvidia control panel gives you when you click add. No .exe file was visible under users/*my name*/AppData/Roaming/Spotify.

Eds89
Music Fan

What impact does this have on other apps running at the same time which do handle G-Sync correctly?

 

If the app is running, does it disable G-Sync, as I wouldn't imagine it can selectively enable/disable G-Sync on an app by app basis?

 

Is this a Spotify issue? No other app I have misbehaves like this.

oliverrau
Casual Listener

This "fix" did disable G-Sync completely for me. And not only when Spotify was running, but also in general for all games etc. After I did re-activate G-Sync (as described in an earlier post) the problem with Spotify was fixed without any additional configuration in the Nvidia control panel.

tshum
Regular

That did it for me. Thank you!

oliverrau
Casual Listener

This for sure does fix the issue, but be aware that it also disables G-Sync in general (for games etc). To re-enable it again you have to revert the setting, followed by disabling and enabling it (in the "Set up G-Sync" tab) once.

Baibro
Newbie

Same problem, Recently got a new pc, specs are i9 and 2080ti so this is not a performance issue of my pc. I also have 144hz gsync monitor, this did not occur on my old PC or laptop which had 60 hz non gsync screens. Also only when window is in focus.

SynysterNght
Casual Listener

Im having the same problem.

Whenever spotify is focused the frame rate goes down from 144Hz to 39Hz.

Im using an Asus Monitor with G-Sync.

samdief
Newbie
I know its late... But I've found that instead of changing the settings to "Fixed Refresh" I changed it to "G-Sync" and that worked much much better.

bladE_666
Casual Listener

Confirmed! Nowadays these minor bugs among others are just bypassed (treated as nonsense junk).

SUGGESTED POSTS