Spotify Windows player Discovery screen frozen display

Solved!
Reply

Spotify Windows player Discovery screen frozen display

user-removed
Not applicable

Hello!

 

After the recent update, the discovery screen appears to freeze up graphically on my computer. I can still click links that are 'invisible' and even scroll down and things seem to move by (although I don't see any change except that my mouse pointer turns into that pointing hand that normally shows up when you mouse over a link; the locations that it turns into a pointer change). All other sections appear to work just fine in the desktop app.

 

It seems that the page just doesnt render beyond the point to where it finishes loading, no content shows up at all, but it's there... just not graphically.

 

Was there some kind of change in how the discovery section renders? Maybe using hardware rendering or something?

 

Edit: this affects Apps as well, or at least so far the Pitchfork app.

2 ACCEPTED SOLUTIONS
Solution!

user-removed
Not applicable

According to this doc here, which shows Chromium switches, the following spotify.exe switches can be used to switch off various hardware/GPU accelerations in Spotify. This might be handy for anyone who has experienced issues after latest version switch to 0.9.4.169.gc0399df6

 

Here's a few that I started with,

 

--disable-accelerated-video
--disable-accelerated-plugins
--disable-accelerated-overflow-scroll
--disable-accelerated-layers
--disable-accelerated-fixed-root-background
--disable-accelerated-compositing
--disable-accelerated-2d-canvas

 

You can make a shortcut with the switches or a batch file.
You can also just run the following from Run or a CMD prompt. If it fixes your problem, remove a switch one by one and then you'llknow exactly what needs to be disabled.

 

%APPDATA%\Spotify\spotify.exe --disable-accelerated-video --disable-accelerated-plugins --disable-accelerated-overflow-scroll --disable-accelerated-layers --disable-accelerated-fixed-root-background --disable-accelerated-compositing --disable-accelerated-2d-canvas

 

Using all of these spotify.exe switches fixed it, so I whitled it down to the culprits; these here:

 

--disable-accelerated-layers

--disable-accelerated-fixed-root-background

 

obligatory edit: added spotify version

View solution in original post

Solution!

Peter__
Community Legend

If you are on Windows:

 

Completely exit Spotify.

 

Hit start > type "run" > hit enter, copy and paste:

%APPDATA%\Spotify\spotify.exe --disable-accelerated-layers --disable-accelerated-fixed-root-background

into the box and press ok. 

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

View solution in original post

68 Replies

Peter__
Community Legend

Thanks - I'll make sure that gets passed over to the Spotify team. 

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

meahtenoha
Spotify
Spotify

Hey guys! @DJSmooth @loveangelica63 @mollygauss77 Could you all please confirm:

 

1. You've tried the previous troubleshooting (updated graphics card)

2. Your OS and Spotify app version

3. Post screenshots of what you're seeing if possible

 

We'll take it from there!

mollygauss77
Regular
I am using OS Windows 7 32-bit and Spotify version 0.9.6.72.ge389c074 How do you update the graphics card? I tried downloading an older version of spotify (one from a few months ago) and it let me send music. So it is definitely something going on with the updated version.

mollygauss77
Regular
Can you please advise how to try the previous steps? Attached is a screen shot. Thank you very much.

mollygauss77
Regular
Can you please help advise how to get to this place on my computer so I can try to fix this issue via switches? Thank you.

mollygauss77
Regular

I am having issues sharing music as I am getting a white box popup everytime I click "Share to" and came across this post. It seems like you were having a similiar problem. Can you please assist me with how you fixed this? THANK YOU!

DJSmooth
Roadie

I am having the same problem, my share button gives me a white/blank box, I've reinstalled but still not working, going on 2 weeks now. this is a work computer running windows 7, any help?  As a premium user i'd like tho get this sloved and working properly.  Thanks for the help 

mollygauss77
Regular
Is yours working now? I am still having the white box appear and am extremely frustrated.

Peter__
Community Legend

There is an update of the client rolling out from today which will hopefully (my fingers are crossed) fix this issue. Just click on the restart to upgrade banner when the rollout reaches you.

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

mollygauss77
Regular
Thank you for the response. I am still experiencing this issue and as a Premium user for over 2 years now, I am very frustrated that this problem cannot be fixed. Please help. Thank you.

Joe
Community Legend

Have you tried adding the switches mentioned earlier in this thread to your spotify shortcut?

mollygauss77
Regular
Can you please explain further how to add those switches?

davidsteltz
Newbie

I am having the same issue described here...light blue blank screen on artist pages, discover page, etc. Spotify Version 0.9.4.178.g259772ba

 

I tried using Robt_Jamin's switches to no avail, and yes, my GPU driver is up to date.

 

Has anyone found any other solutions?

 

UPDATE:
The issue seems to have resolved itself for me; not sure what did it exactly, but I assume the update fixed the bug, as I am now running version 0.9.4.185.g7545a404 so thanks, Spotify!

Downfall
Casual Listener

The post above this post resolved my problem completely. I added " --disable-accelerated-layers --disable-accelerated-fixed-root-background" to the end of the shortcut's path and voilá: Spotify runs just like before. No crashing and Discover-page looks normal again. Thank you!

 

It would be nice to know which part of the system confilcts with the new Spotify configuration: the GPU, OS or what?

 

Once more, thanks a lot. Saved my day.

Peter__
Community Legend

@user-removed - That is excellent work! 

I would imagine you have made quite a few peoples days - I will make sure this gets passed over to the Spotify teams. 

 

We are also getting several reports that updating your graphics card drivers from your vendors website will fix this issue. 

So it is probably a good plan to find out what type of card you have and hitting up nVidia/ATI/Intels site for an update 😉 

 

Peter

 

Edit: Adding driver details. 

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

Rollo_
Roadie

Really, awesome.  I've started Spotify from the command line, but never bothered to look for any switches.  How did you find them?  Traditional methods don't seem to work.

Rollo_
Roadie

If you look at the "spotifyhelper.exe" processes in Task Manager or Process Explorer, do you have one that's eating up a ton of memory?  I found that to be the case with the swarm.fm app.

 

Just looked, spotify.exe using ~150mb, ONE spotifyhelper.exe process at nearly 250.  I browsed away from swarm.fm to a different app, memory usage back to normal within a few seconds.  But it least it didn't freeze up Spotify 100% like it would in previous versions.

 

I didn't notice anything unusual while browsing Discover, but, as they say, YMMV.

user-removed
Not applicable

I do see 5 spotifyhelper.exe processes running, and tried forcing all to close and reopening. Even tried a reboot just now. The spotifyhelper processes total about 100 megs altogether, which is no worry at all for the system it's running on.

 

It doesnt appear to me to be a resource related issue to me, more of a change to the way Spotify renders the Discover 'page' and other similar Apps that use the same framework.

 

I'd really be interested in finding out what change happened between 0.9.4.169.gc0399df6 and the previous version as far as how the Discovery page is displayed.

 

Peter__
Community Legend

@user-removed - There is a little more detail about the 0.9.4 changes in the release notes topic. You are correct, there was a framework change which means the pages are being rendered in a different way and the client now uses hardware acceleration on graphics cards too.

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

user-removed
Not applicable

@peter - I thought I recognized the glitch. It explains a lot that Spotify went to hardware acceleration. Chrome had this glitch with my desktop customization software as well (yes, totally guilty of messing with the default windows config). I'm using bbLean 1.17.1 x64 (Forum Page Link) and it conflicts with chromium hardware rendering 😞

 

I bypass this glitch by turning off hardware rendering in Chrome. I'm gonna go see if I can do that in Spotify and post back.

Downfall
Casual Listener

Something has gone terribly wrong somewhere recently.

 

Since today, I'm unable to run Spotify unless it is in compatibility mode (WinXP SP3). If I try to run it normally, it will crash with the message "Spotify has stopped working" and then shuts down. When I run it on WinXp mode the Discovery-page is either blank or only partially loaded but the rest of the desktop-application seem to work fine. The music plays normally and the UI seems quite the same as in the normal mode. The XP mode clearly strips out some portion of the program that causes it to crash immediately after log in if ran normally.

 

Exactly the same problem occures with Adobe Creative Cloud "application manager", the small program that lists the available applications, updates etc. Immediately after I run it it crashes with the same error message as Spotify. The Creatice Cloud UI seems to use some same elements or framework as Spotify. 

 

So, what on earth is wrong with what? These two problems are very similar in nature and they occured almost at the same time.

 

I'm using Windows 7 Pro 64bit with nvidia gpu.

 

 

SUGGESTED POSTS