Spotify starts with Windows, even when disabled and it's really pissing me off

Reply
Highlighted

Spotify starts with Windows, even when disabled and it's really pissing me off

Casual Listener

Plan

Premium

Country

USA

Device

Windows 10 desktop PC (i5-4460, 8gb ddr3 ram, GTX 1070ti, Samsung SSD)

Operating System

Windows 10

 

My Question or Issue

 

Ever since I first downloaded Spotify months ago it has been opening on startup when I turn my computer on and it's driving me absolutely nuts. This feels like the buggiest app I've ever used.

* 'Open Spotify automatically after you log into the computer' is always off.

* I've tried with the windows 10 store app as well as the standalone from Spotify.com.

* I've uninstalled and reinstalled several times.

* I'm not reinstalling windows and there's no reason I should.

* I've already seen this: https://community.spotify.com/t5/Desktop-Windows/Open-Spotify-Automatically-Setting-Don-t-Work/m-p/4...

* and this: https://community.spotify.com/t5/Spotify-Answers/How-do-I-stop-Spotify-from-opening-automatically-on...

 

I'm tired of seeing this app jump in my face, flash its icon on my taskbar and demand my attention, slow down my computer while booting and joining the array of other apps that opens and focuses themselves just as I try to click something one after another, forcing me to not use my computer until everyone has had their turn jerking off in front of me.

Please help I'm getting really sick of this.

5 Replies
Highlighted

Re: Spotify starts with Windows, even when disabled and it's really pissing me off

Casual Listener
Same, it's immensely annoying
Highlighted

Re: Spotify starts with Windows, even when disabled and it's really pissing me off

Casual Listener

I figured it out. If you have Spotify open when you tell Windows to shut-down, hoping Windows will just close Spotify for you, then when Windows is next booted up, Spotify will ignore what option you selected and open anyway.

This is stupid, and there should be an option to disable this functionality.

My workaround is to manually close Spotify by clicking the X (and closing it from the system tray if you have that functionality enabled) before you tell Windows to shut-down.

I'm not going to mark this as the solution, because the problem is still here. The functionality is still broken and I'm still annoyed. This is a workaround, not a solution.

Highlighted

Re: Spotify starts with Windows, even when disabled and it's really pissing me off

Visitor

Did you already look in Task Manager if Spotify is enabled there?
If not so, press CTRL + ALT + DEL and click on Task-Manager.

Then, go to the tab called "Autostart" and look out for Spotify. You can sort the programs for being enabled or not.

When you found Spotify, look right if there stands "Enabled". If it does so, make sure Spotify is selected from the list and click on "Disable" on the lower right corner of the Task Manager.

Now, log out of your computer and log back in again and look if it still starts.

Hope I could help you,

Gamesnic

Highlighted

Re: Spotify starts with Windows, even when disabled and it's really pissing me off

Casual Listener
Highlighted

Re: Spotify starts with Windows, even when disabled and it's really pissing me off

Visitor
Ditto. Same on Macook Pro. driving me nuts. Have uninstalled & re-installed but still opens at log-in & slows everything down. W'ont even quit.... have to force quit & can't open anything else until this occurs! Tenmpted to cancel permanently......but will try a solution below.
SUGGESTED POSTS