Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


autoplay problem

autoplay problem

i have switched autoplay off but i am still getting unwanted tracks interfering with my listening
2 Replies

Hey there,


Thanks for posting in the Community and welcome.


In this case, would you mind sending us a detailed description of exactly what is happening on your side? Does this happen when playing specific playlists or does it happen no matter what content you choose to play? It might be worth checking if you've activated the Enhance feature on the playlists in which you've noticed this behavior.


On another note, would you mind giving us more details about the device on which you noticed this behavior? Can you send us the make/model and OS along with the Spotify version you're running there?


Lastly, and just to confirm, is your account on our free tier or is it Premium? The behavior you've experienced could be expected if perhaps your account is free and you're using it on a mobile device. Keep in mind, music on-demand is a Premium feature, free accounts work differently on desktop apps and web players. You can read more about the free experience here.


Keep us in the loop!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

I'm looking to turn off autoplaying "similar music" once a playlist ends. The setting doesn't show up where it should. I've already followed the instructions, including and not limited to, "go to the account/profile tab, click on settings, and scroll down to turn off autoplay," and, "go to playback in settings and turn off autoplay there". It doesn't exist. I'm using Spotify via browser, on a Chromebook.

Suggested posts