Downloading on Apple Watch stuck at first song

Hey folks,


We're receiving reports that some users are unable to download music for offline listening on their Apple Watches. The download is stuck on the first song and doesn't progress.


If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.


We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 



Hello everyone,


We want to confirm, we're still investigating this. We're gathering your reports and passing them on.


Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.


When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.


As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.


Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection


We’ll get back to you again when we have new info. Thank you!


mine does not want to play from the watch. 

Mot does not connect. The watch logo is white and keeps flashing. 


No changes. Does not download pass 1 of… and stream mode does not work for me either. white watch logo keeps flashing trying to connect. 


Hey folks,


Thanks for the info 🙂


Could you try the following steps to see if anything changes:

  • Restart the devices.
  • Reinstall the app on the watch.
  • Re-pair the watch with your phone.
  • Start playback of the playlist and then start downloading it.
  • Ensure you're on a stable WiFi connection. You can also try with another WiFi to see if that makes a difference.

Let us know how it goes.

There is no updates..
Just not impressed by spotify blaiming network connections, battery charge, bad pairing to watch etc.. Of all the people that complained..
Horrible customer service..
It just seems like the feature is completely broken. Finally it now says all my songs in a playlist have downloaded onto watch but then they won't play? The Spotify app on my watch just doesn't respond and won't play any music to my AirPods independently.

Has a bug been raised to look in this? I'm happy to chat to someone directly to help diagnose the problem.

Hey folks!


Thanks for your messages.


We can report this to the teams in charge. In order to do this, could you let us know if you've tried any of the previous suggestions?


It would also be helpful if you could provide the following info if you haven't already:

  • The exact OS/firmware version and the Spotify version you're currently running on your phone and your watch.
  • Some pictures where we can see how the issue looks from your end.

We'll keep an eye out for your replies 🙂


Worked for me after force quitting the app on the watch. 

When app is open, hold side button until the 3 sliders appear. 

Hold Digital Crown until the app is closed. 

Restart the app.

Managed to fix it by uninstalling the Spotify app on my watch, resetting my watch then reinstalling.

Hey @AgentMax and @alexmichie,


Thanks for your replies.


We're glad to know that it was sorted out and appreciate you sharing what worked for you, as it may be helpful for other users as well.


If you need a hand with anything else, the Community is here for you.


Cheers 🙂

I turned on airplane mode and allow my apple watch to connect to wifi only.
Then only it starts to download; if it is connected to my phone, it will never start the download and stuck at 1 of x forever.

Appreciate Spotify could do more extensive testing before releasing to the public

Env: prod