Error code: 30

Plan

Premium

Country

United Arab Emirates

Device

Macbook Pro late 2019

Operating System

OS X

 

My Question or Issue

I repeatedly get the firewall error message and I've run every fix suggested on this community. It simply refuses to work. It works perfectly on my Android phone however.

 

Screen Shot 2020-03-05 at 9.24.50 PM.png

Hey there folks,

 

Thanks for reporting this here in the Community!

 

Our tech teams are currently looking into this.

 

If you're unable to log in and see this error message, we'd fist recommend trying the following:

  • Perform a clean reinstall with the steps here
  • Check the firewall on your device and make sure Spotify is "whitelisted"
  • Disable any antivirus software temporarily to see if that helps - if it does, make sure to set Spotify as an exception
  • Turn off any VPN, if in use
  • Check that the proxy settings are set to default (auto-detect)
  • Check the host files (steps can be found here for Windows device and here for MacOS devices)
  • Switching to another internet connection (WiFi, mobile data via tethering, or going direct via LAN cable)
  • Using other devices and a different computer, if available
  • Try logging in with a different account to see if that helps
  • Accessing the Spotify Web Player before re-attempting to log back in to the desktop client
  • Running Spotify on Safe Mode

If the issue persists, feel free to add your +VOTE to this thread and make sure you've subscribed in order to get the latest news here.

 

For now we'd recommend always keeping your Spotify app and all devices fully up-to-date.

 

Thanks!

Related Issues

Comments
Visitor
Thanks! That worked!
Newbie

Thanks @roriblack !

I literally tried everything and way more that what mentioned in this thread, nothing worked except your hint.

In case of a corrupted Win 10 registry I had to completely wipe my old system. (Spotify worked for me until this time for years without any problems) Than on a fresh installed Win 10 Pro with all updates and only Google Chrome and Kaspersky installed, Spotify wont work for me [Error 8 (Firewall) and 3] . But on my phone, TV, Spotify Web Player and Playstation it worked fine and I could login/out as often I want. I also created a new free account, guess what... it worked on my PC but not the solution I need. Firewall, drivers etc. were not the problem at all. I could only login to my origin premium account after installing an older Spotify application. As well updating to the newest Spotify was no problem anymore. 


Visitor

Make sure Spotify has a green tick beside which means the rule to let it through is enabled, if not right click and hit properties then check the box "enabled"

elliot_north_0-1587205985944.png

 

This is how I got mine working.

Regular
Hey there,

Can you elaborate on what you mean by "green tick"? As in, where should I be seeing that and how might I enable it to let Spotify through?

Thanks for replying to me, I appreciate the help!
Moderator
Moderator

Hey all, 

 

For those of you who're still experiencing this, would you mind quickly double-checking everything is OK with the host files (steps can be found here for Windows device and here for MacOS devices)?

 

We're looking forward to your updates and we're here for you in the meantime!

Regular

I just started getting this error today, before that everything was working fine. I'm on Windows 10.

Regular

Same issue
File version 1.1.30.658
I am currently getting the accesspoint 34 error...  I have followed all the steps and have got no resolution on my Win 10 laptop... apart from once when I tried to log in again and got a "service is not available" error instead of the firewall error 34 warning.
turning the firewall on and off makes no difference, it still says a firewall may be blocking Spotify. This is the second time in as many months that I have gone through this error this with no apparent changes to any security software (indeed when I tried to add spotify permissions again it told me the entry already existed so I deleted the entry and reinput a new firewall entry for it).

Today I have uninstalled, reinstalled, restarted laptop and router, and got nowhere, at least when I did this a few onths ago a fresh installation eventually seemed to sort out the "no cnnection to the internet" issue... but not this time.

I've looked on various "is x down" sites and I'm not alone in my area... so maybe there is a block on spotify app traffic somewhere else on the BT network?

 
Started Sunday 19th april with "Offline not connected to the internet" type error. Restarted laptop, restarted router, followed suggestions found about checking spotify settings... none worked or cleared the "not connected to the internet".
Persisted Monday 20th, same procedure, nothig  cleared it.

Tuesday 21st, still "no access to the internet" error.

Uninstalled and reinstalled (for the second time in two months - for the same same problem). now on version  1.1.30.658 and cant log in... service is unavailable.

The Spotify on  my android is working fine as is the web browser version... just the downloaded Windows app thats failing AGAIN.
have checked firewall settings and the app has permissions in and out.

If I am honest if I have to reinstall this thing every month (and so far this year thats happened twice for the "No Internet connection error) then i will  uninstalll permanently from the laptop and find a different music streaming service as this seems to have been ongoing for years on the desktop app

Moderator
Moderator

Hey@SandanistaUK and @maniluvsu!

 

Thanks for reporting this to us. We'll forward your feedback to the right team here but we'll also need to know if you've modified your host files. 

 

Could you double check that with the steps that @Mario describes above and just let us know.

 

We appreciate your cooperation on this!

Regular

Hi @Elena I have already checked my host files and everything looks normal. (Actually my host files are completely empty and idk if that's normal or not but there's nothing there besides a large block of comments.) I've tried troubleshooting all of the solutions in this thread (except for downloading an older version of spotify and updating from there - I'll try that next).

Visitor

Hello. I can`t use my spotify account on my pc(reason why I bought it) for a few months now. I`m still paying the subscription. Can we please get this solved?


Edited: Fixed by removing spotify from hosts file.