[Mac Desktop] Can't Play Current Song Error Message

Plan: Premium for Students

 

I have a MacBook Pro with macOS Catalina Version 10.15.6. For about the past month I have been getting an error message when trying to play Spotify on my laptop. I will play a song and it will play the entire song except for the last two seconds. At that point it'll stop and I get an error message saying "Can't play current song." It will not progress to the next song until I hit the next button and then the whole thing will repeat. If I hit pause/play, nothing happens. The Spotify app on my phone is working totally fine.

 

I have tried restarting the application, logging out, restarting my computer, uninstalling and reinstalling. Also, off of other suggestions, I have tried turning off autoplay and crossfading songs. I have tried looking for the Spotify cache history and haven't been able to find any (but that also might just be above my computer skills). 

Hey there folks,

 

We really appreciate you sharing your details as requested! Rest assured that our teams are still looking into this.

 

If you're also having trouble playing any track in the desktop app, first try the steps here and if that doesn’t do the trick, make sure to add your +VOTE and a comment with the following info:

  • The device(s) (make, model & OS) this is happening on
  • The exact Spotify version
  • Do you have headphones or external speakers connected (Bluetooth/wired)?
  • Is the behavior always the same?
  • Can you recreate it with ease, or is it random?
  • What troubleshooting steps have you tried (eg. changing networks, turning off Proxy or VPN, restarting your device, setting the app Offline, checked the firewall, etc)?
  • Any screenshots or screen recording of what's happening would be very helpful - just make sure that there's no private/sensitive info displayed.

We'll be keeping you updated here on any info we have to pass on so we'd suggest ensuring you've subscribed to this thread to stay up to speed. 

Comments
fraig
Visitor

Premium Family Plan

UK

 

Device

Macbook Pro 13inch Early 2015

Operating System

Mac OS 10.14.5

 

In the last few days, whenever I pause music on the desktop app, when I come back to it later and press play, the seek/time bar moves along as if the track is playing, but there is no audio. After about 3-4 seconds, a blue warning message appears at the top saying "Can\t play the current track". This has happened on my playlists, collab playlists, albums and spotify created playlists (discover weekly etc)

I'm not offline. The blue offline message DOES NOT show. The internet connection works in other applications, and also in Spotify (eg if I start browsing artist content or doing searches for previously unsearched content, it all works).

The only way I can get music to play is buy quitting the app and starting it again.

8_i6z45-bnm8j
Newbie
This has started happening to me too, but only after i started using Bluetooth headphones. Did you start using another Bluetooth device or something?
milk_milk
Visitor

I'm using a 12" Macbook from 2017. Since I started to use my new Bluetooth headphones, this issue has been bothering me. This issue only seems to occur when I am on Mac with Bluetooth headphones. It greatly frustrates me as well. 

8_i6z45-bnm8j
Newbie
What headphones are you using milk_milk? Mine are Sennheiser HD 4.50BTNCs. i just want to see if it's a headphone-specific issue or if it's the Mac's fault.
fraig
Visitor

I am using bluetooth earphones yes. But I have been using the same ones for a few months. My earphones are Jaybird Vista. Bluetooth 5, although my mac only supports Bluetooth 4.2 (I think).

 

To clarify, when the problem happens, audio from other sources (youtube, microsoft teams etc) work fine, so it's not a problem with the earphones.

8_i6z45-bnm8j
Newbie
Yeah other apps work fine with mine too. I just tried turning crossfade on, but set it as 0 seconds and it seems to have fixed the issue for some reason.
8_i6z45-bnm8j
Newbie
Edit: Doesn't work anymore
8_i6z45-bnm8j
Newbie
Unless you're an iPhone user and you use the Handoff setting, I'd suggest turning it off. After i turned it off, my headphones stopped the audio stuttering and so far i haven't had the can't play song issue. Something to do with that it runs at the same frequency and disrupts the headphone connection. Even if it doesn't stop the 'can't play song' error i think it's worth a shot because it improves audio quality as well. It's in System Preferences under General.
milk_milk
Visitor

I tried turning the feature off. However, the problem persists. Nevertheless, thank you.

nicktayloruk
Newbie
This has been happening to me too, for quite a while. I also use Bluetooth headphones, so maybe this is part of the reason, although I don't need to pause via the headphones for this problem to occur.