Announcements

Podcasts not playing on external devices

Podcasts not playing on external devices

jazzpazz

Plan

Premium

Country

Australia

Device

iPhone 12 Pro, MacBook Pro, Google Nest Hub, Google Nest Mini, Google Home Max

Operating System

iOS 15.1.1, MacOS 12.01

 

My Question or Issue

 

Spotify podcasts stopped working on Google Home connected speakers.

 

1. When I ask Google Home to play Spotify podcasts, or when I cast from my iPhone to a Google speaker and try to play a podcast, nothing happens.

2. When a podcast episode comes up in a playlist (e.g. Daily Drive) while the playlist is playing on a Google speaker (either direct or casting), the episode is skipped without notice and only music tracks are playing.

 

The issue became apparent this week but might have been present in December 2021.

 

Steps taken already did not resolve the problem:

- logged out on Spotify mobile

- updated Spotify on mobile

- unlinked and re-linked Spotify in Google Home app

- restarted my router

 

Please help!

Reply
Top Answer
Elena
Moderator

Hey there,

 

Thanks for all the posts and shared experiences.

 

We're currently investigating the reasons behind this issue and would like your further input by providing the following information to pass on to the tech team:

 

  • Is this issue podcast specific? If so, we'd need an URI to the affected podcasts.
  • Which devices are affected exactly? Brand/model and OS/firmware version.

Thanks a lot for all the help,

 

Cheers!

92 Replies

ericachase

Plan: Premium

Country: USA

Device: iPhone 13, MacBook Pro, MacBook Air, variety of Amazon Echo devices (all devices up to date)

 

My Question or Issue:

 

Hi there! I'm a bit at the end of my rope. Ever since the 8.6.62 Spotify app update two weeks ago, my Echo devices no longer recognize podcasts played from Spotify. When I tell Alexa to play Spotify, she announces the name of the podcast plus "Now playing from Spotify", but then nothing happens. When I try to select a device from my phone or desktop Spotify app while playing a podcast, nothing happens, almost like the app didn't even recognize the input. These are all podcasts that, prior to the 8.6.62 update, worked just fine with Echo devices. Music also works fine, just podcasts are the issue. 

 

I have uninstalled and logged out of Spotify on all of my devices. I have unlinked and relinked the Spotify skill from the Amazon Alexa app. I have removed and reset all of my Echo devices. I have reset my network. I've toggled allowing only local devices. I've tried playing maybe 30 different podcasts in case my usual podcasts stopped being supported, but NONE of the podcasts would play. I don't know what else to do. Someone on Reddit said they had to create a whole new account JUST for podcasts, which, to be frank, is a ridiculous solution. 

 

Would appreciate any help, thank you!

 

MafeG

Hi @ericachase,

 

Thank you for reaching out to the Community!

 

Great troubleshooting so far. We'd like to keep narrowing this down, so can you log in with another account, such as a friend's or a family member's to see if the issue persists? Alternatively, you can create a free account here, just make sure you're logged out of your own account before creating a new one.  

 

Let us know how this goes.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

ericachase
Hi there! I live alone so I can't have another person connect to my Echo devices right now. I created a new free account, but I can't play podcasts to Echo devices without a Premium account, and I'm not going to pay for a second Premium account just to test this.

Eni

Hey @ericachase

 

Thanks for your reply. 

 

In this case, we suggest that you try following these steps:

  1. Unlink your Spotify account from the Alexa app.
  2. Perform a clean reinstall of both the Spotify and Alexa apps. You can find instructions on how to do this for Spotify here
  3. Link both accounts again. This article will show you how.

Hope this helps. Keep us posted on how it goes.  

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

running_photogr

I am having the same issue. Spotify plays music just fine on Alexa, but podcasts no longer work. I have tried all of the basic troubleshooting like unlinking accounts, resetting devices, etc. Even if I start playing a podcast on Spotify from my phone or laptop and try to connect to an Alexa device it won’t play. 
This issue has been going on since December and I can’t find a solution anywhere. 

running_photogr
I have tried getting help from Amazon support, but they could not solve the issue.

jazzpazz

I have the same problem but for Google Home devices. Music works fine when I cast to a Google speaker or initiate playback from the speaker itself. However podcasts do not. When I try to play a podcast from Spotify nothing happens. When a podcast episode comes up in a playlist (e.g. Daily Drive) the episode gets skipped and only music plays. Started happening in December 2021.

Kiril

Hey @jazzpazz and @running_photogr,

Thanks for posting about this in the Community!

@jazzpazz we understand you're not being able to hear podcast contents being streamed on your Google Home devices. Could we ask you what troubleshooting steps have been done so far and also what is your current version of Spotify? If your applications and also devices' firmware are outdated, then please run all pending updates as soon as possible. If this doesn't help then you can run one clean reinstall of the app, as this is more thorough than the normal one and ensures that no previously cached data can cause performance issues. See if after the reinstall there is any difference for you, also you can check our suggestion below and try with a different account. 


@running_photogr, because the reports we're receiving here are mixed in nature and seem to vary across different platforms, it's also worthwhile to try linking a different Premium account (maybe ask a friend or relative when possible) and to see if the same behavior occurs for that account too. We ask this, to be able to rule out the possibility of the issue to be specifically related to your personal account as well.

Hope you find this useful. Keep us posted, we'll be on the lookout for your reply.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Ver

Hey @jazzpazz,

 

Thanks for posting here.

 

The troubleshooting steps that you've tried so far are very good. We'd like to add a few more.

 

Could you give these steps a go and run a clean reinstall? This one is more through than the usual one.

 

It's also a good idea to try with another account to see if anything changes.

 

We'd suggest you also check the devices' firmware if is up-to-date.

 

Keep us posted.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

jazzpazz

Hi Ver! Thanks for your response.

 

I've followed those steps and the problem persist. I don't see how re-installing the mobile app would make a difference as this is a problem across both Spotify for MacOS and iOS as well as calling Spotify directly from the smart speaker with no casting device involved. It does not seem to be connected to the Spotify app nor my laptop or mobile device in any way. The problem seems to be behind the scenes in delivering podcasts from the Spotify service over the internet to the smart speaker. Again, music will play just fine but podcasts are ignored (no response given).

 

This is my setup:

 

2x Google Nest mini 

- System firmware: 282045

- Cast firmware: 1.56

 

2x Google Nest Hub 1st Gen

- System firmware: 4.20210608.1.1146047

- Cast firmware: 1.56

 

1x Google Home Max

- System firmware: 275994

- Cast firmware: 1.56

 

Spotify for MacOS (Intel)

1.1.76.447.g11f432d8

 

Spotify for iOS

8.6.94.351

 

jazzpazz

Thanks for your response @Kiril!

 

Troubleshooting steps so far included:

 

- clean reinstall of the Spotify iOS app

- rebooting my router, phone and smart speakers

- resetting the Google Nest mini speaker

- deauthorising and reauthorising Spotify on Google Home

- playing podcasts through Google Podcasts instead of Spotify on the smart speaker (this worked)

 

This is my setup:

 

2x Google Nest mini 

- System firmware: 282045

- Cast firmware: 1.56

 

2x Google Nest Hub 1st Gen

- System firmware: 4.20210608.1.1146047

- Cast firmware: 1.56

 

1x Google Home Max

- System firmware: 275994

- Cast firmware: 1.56

 

Spotify for MacOS (Intel)

1.1.76.447.g11f432d8

 

Spotify for iOS

8.6.94.351

 

Firmware is up to date on all devices.

jazzpazz

So I've now tried connecting a different Spotify Premium account and everything works as expected. This narrows the issue down to an account issue.

Alex

Hey @jazzpazz,

 

Thanks for the detailed info you've submitted.

 

Can you let us know if podcast episodes play if you start them on your phone/ pc and then switch to the smart speaker via Spotify Connect?

 

Looking forward to your reply.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Alex

Hey @jazzpazz,


Thanks for the reply.

 

In this case we'd recommend using the other Spotify account for a couple of days just to test this out. If everything keeps working fine in the new account, you might consider transferring your Music collection over to a new account. You can follow this Guide.

 

Note that you won't be able to transfer your Premium subscription over.

 

Hope this helps. Don't hesitate to reach out again if you have questions.

 

 

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

grayhassmann

That’s the very action she is trying to perform and stated isn’t working. Using Spotify Connect by selecting Alexa/Google devices from the app is NOT WORKING. 

grayhassmann

I’m experiencing the same issue as everyone here. I have performed ALL of the troubleshooting methods recommended here and elsewhere multiple times over several weeks.

 

Today I tried to log into a separate account on my Premium Family plan. IT WORKED. I was able to utilize Spotify Connect to play a podcast from my iPhone to an Alexa device on my network. It worked.

 

However, after switching back to my personal account, it did NOT WORK—exactly as before.

 

You mentioned that Spotify’s error may be occurring in the specific account itself. What are your recommendations to solve the Spotify error occurring on my specific account? This error has prevented me from enjoying the Spotify experience I’m paying for many months now. 

Please reply as soon as possible. 

Thank you.

tripllle

This same thing has been happening to me since December and I cannot believe the official solution is: make a new account.

 

Infuriating, as Spotify continues to push its lackluster podcasts product on users AND incentivizes creators to be exclusive to the platform.

jazzpazz

Hi Alex! Thanks for the response. Unfortunately that is not an option. I used another person's Premium account to test this out. I'm not able to continue using their account or take over their account altogether.

 

I have narrowed down the problem to an issue with my Spotify account. There has to be something Spotify can do to make the account work as it is supposed to.

jazzpazz

@tripllle Have you changed your plan/subscription recently?

Suggested posts

Env: prod