Help Wizard

Step 1

NEXT STEP

Podcasts not playing on external devices

Podcasts not playing on external devices

Plan

Premium

Country

Australia

Device

iPhone 12 Pro, MacBook Pro, Google Nest Hub, Google Nest Mini, Google Home Max

Operating System

iOS 15.1.1, MacOS 12.01

 

My Question or Issue

 

Spotify podcasts stopped working on Google Home connected speakers.

 

1. When I ask Google Home to play Spotify podcasts, or when I cast from my iPhone to a Google speaker and try to play a podcast, nothing happens.

2. When a podcast episode comes up in a playlist (e.g. Daily Drive) while the playlist is playing on a Google speaker (either direct or casting), the episode is skipped without notice and only music tracks are playing.

 

The issue became apparent this week but might have been present in December 2021.

 

Steps taken already did not resolve the problem:

- logged out on Spotify mobile

- updated Spotify on mobile

- unlinked and re-linked Spotify in Google Home app

- restarted my router

 

Please help!

Reply
Top Answer
Maria
Moderator

Hey there folks,

Thanks for posting in this thread!

We've done some further investigation and looked into this with our teams, and it seems like certain podcasts may not be playable while using the Connect feature. We constantly work on improving the app and its features, that's why we appreciate you taking the time to raise this with us.

Keeping our fingers crossed even more podcasts become available in the future!

If anything else appears, we're just a post away.

151 Replies

I'm also having this issue, but on my desktop. Music plays fine through my desktop but no podcasts will play audio. If I log out of my account, the podcasts will play, but not if I'm logged in. Works fine on my phone. And it's not on every desktop app; my home laptop works fine, just not my work computer.

Which is why I keep reviving this thread. I can listen to whatever I want on the work PCs. But I have to do it through the web browser. The fact that podcasts don't work is so irritating and makes no sense.

Hey @karmonia and @idontgiveaf___!

 

There's this recent ongoing issue about podcasts not playing were currently investigating, so feel free to check it out if you haven't already as we'll be posting updates there.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Randomly... mines had all started working now.

 

Can play podcasts from phone on echo devices using Spotify connect.

 

No idea why or how... but it's working.

It’s working here too. Maybe they’ve been fixed this, finally 

Think mine's working now. Cheers Spotify for fixing it. Hope everyone else's is sorted too

Web player is definitely still broken for me. Not even trying to play it through my Android device makes it work on my PC.

It is working for me too, after months of being completely unable to play podcasts on smart speakers, now I can do it again.

Hi folks, 

 

Thanks for your replies. 

 

Glad to hear it's working for most of you again.

 

@idontgiveaf___, can you let us know what browse you're using and if you're using a VPN.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This is a new problem for me. Only began about 3 weeks ago. 

I listen to The Daily from New York Times. Appears to be playing but now sound via AirPods, multiple models of aftershokz headsets, Bose speakers, Sonos speakers. Began after update to iOS 15.16.4. Now on iOS 16 and it continues. Podcasts such as Hidden Brain also affected. Other like npr up first work fine. 

Just tested on my iPad. Same result. Interesting however, that once pressing play, the podcast timeline does not advance at all as though the episode has been paused. No effect when pressing pause , then play again. 

Hey @Ltam,

 

Thank you for keeping in contact.

 

If it's happening in more than one device when connecting to your Google Home, here's something you can try out:

 

  1. Unlink your Spotify account from your Google Home and then link it again.
  2. In the Google Home app, set the DNS server address to 8.8.8.8 or 8.8.4.4.
  3. Reboot your device.

Alternatively, you can try setting the DNS server address to 8.8.8.8 or 8.8.4.4 in your router's settings as well.

 

Hope this helps. Keep us posted!

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey folks!

Could you update your apps to the latest version and check if the issue persists?
Many thanks!

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Version 8.7.68.568 on iOS. Still unable to play on Alexa devices, tested now:

This is now working for me!
Thanks Spotify for finally sorting it out. 👍

Plan 

Premium 

Country 

Uk 

Device 

iPhone 13 Pro, echo 2021 model 

 

Operating System 

iOS 16 

 

My Question or Issue 

When casting audio from iPhone to Amazon echo device.

 

  • If certain podcasts are being played, the Spotify app displays cannot play this track.

 

  • if you change to play on this device(iOS), it will play no problem on the iPhone,

 

  • If you try to play to a amazon speaker, you cannot play this track.

 

  • if you play to a Bluetooth speaker, it works,

 

  • if you go to the Amazon device and manually, find the podcast it also plays.

 

example of  podcasts that have this issue.

 

  • The Lazarus heist
  • The infinite Monkey Cage.

 

anyone else had these issues?

 

Salve a tutti, scrivo dall'Italia!

Purtroppo io ho lo stesso problema con i miei due Google nest mini! Quando do il comando audio di riprodurre dei podcast di Spotify, l'assistente mi dice o che non può riprodurre podcast di Spotify oppure mi ingnora e non risponde ai miei comandi!

Ho contattato l'assistenza di Google, che mi ha suggerito di chiedere a voi! 

Qualcuno che può aiutarmi?

Hi all, I write from Italy!

Unfortunately I have the same problem with my two Google nest minis! When I give the audio command to play Spotify podcasts, the assistant either tells me it can't play Spotify podcasts or it ignores me and doesn't respond to my commands!

I contacted Google support, who suggested I ask you!

Anyone who can help me?

I've got the same problem here in Germany. some, not all, podcasts just won't play on an external device. I've got that problem with PS5 as well as Echo Dot.

Spotify support has been less than helpful, I'd like to add. The only solution they offer me for three days in a row now, is to do a clean re-install of spotify on my devices, to restart my router and to factory reset my devices over and over again. Rather frustrating...

But I still hope Spotify will find the problem and eventually even fix it, if enough people complain

I finally found a work around. I start the podcast over cell connection then reconnect to WiFi.

I stress this only happens with a couple of podcasts so I wonder why it doesn’t apply to all. And agree that Spotify has been useless in running down this very obvious bug on their side.

I have the same issue, all German podcasts bei ARD are affected (WDR Zeitzeichen, WDR5 Morgenecho, SWR, etc...). Don't know if this a coincidence.

I tried deinstalling several times on all devices. The podcasts only play on phone and Computer, but not on external devices.

Suggested posts