Double Speed Song Bug

Reply

Double Speed Song Bug

smaxwell96
Newbie

I have found a slightly annoying bug on Spotify for iOS that causes music to speed up (approx. 2x speed). It has only occured twice, but I would like to make Spotify's developers aware of the issue so they can solve it.

 

The first time, I had paused Spotify on my iPhone, then later hit play on a bluetooth device I had connected to my phone. There was no response the first time I hit play for several seconds, so I hit it 2-3 more times until the music started. The music playback was at around 2x speed for several songs (I wanted to see if it would fix itself) until I started a song over, which fixed it. This was on version 5.3.0 of the Spotify Music app on my iPhone 6 Plus.

 

The second time, I had been listening to Spotify Music on my iPhone, and changed the song on the Joy for Spotify app for Apple Watch. I then decided to go back to the song I had previously been listening to, so I opened the Spotify Music app on my phone and the song I had previously been listening to was still there, paused, with a dialogue above it that said something along the lines of "Your music has been paused because your account is being used by another device." I dismissed the dialogue and hit play, and the song played at around 2x speed. I started the song over, and again fixed the problem. This time I was using version 5.4.0 of the Spotify Music app, on the same phone.

 

This problem is easy to fix by starting the song over, but I shouldn't have to start my music over every other time I try to listen to it. I hope my reporting of this bug will assist Spotify's iOS app developers in finding and fixing it. Feel free to ask for any other details if you need to. Thanks!

48 Replies

apocomilogin
Newbie

Have same issue as @loyen got BT headphones, when I woke up my MBP then song mostly is playing at higher than normal speed. Quiting spotify fixing issue till next sleep..

 

Device: MacBook Pro (Retina, 15-inch, Mid 2015)

OS: MacOS Sierra 10.12.2 (16C67)

Spotify version: 1.0.48.103.g15edf1ec

nakedmoon
Newbie
same issue here, while play over bluetooth on my headphone or on bmw connected drive
Trying switching other streaming music service supported by bmw

__ds__
Newbie

Happens every now and then om my iphone 6 when I connect to bluethoot-devices (car and Onyx2).

Recorded it with my work phone, 


https://www.dropbox.com/s/bohnzys88vo9tam/Burn%20on%20speed%29.m4a?dl=0

 

emakoutz
Casual Listener
Happens to me at least once every couple weeks. I'm not sure what "triggers" it. I do often switch between the Bluetooth speakers in my car and my ear piece. So there's that. Spotify--please fix it?

emakoutz
Casual Listener
Come on Spotify--this message board has done all the research for you---now find the bug in the code that enables switching devices because that's the common denominator in all of these posts. Looking forward to that software update!

user-removed
Not applicable
This bahavior happens to me *sometimes* when my iPhone connects to the Bluetooth in my car, if the Spotify app had already been open.

Is there a way to 'subscribe' here to know when this is fixed?

GerPole
Casual Listener
This has happened to me too, I really like it though.

GerPole
Casual Listener
This has happened to me at least three times. (All 3 on rainy days interestingly enough). The first time it happened I got about two songs in and tried to figure out why my headphones were on crack (lol). So I unplugged the headphones and reinserted them and the songs returned to normal. The next time it happened, I didn't do anything because I was on a Funk playlist that sounded wonderful with this glitch, I left it on for the entire day but turned my phone off when I went to sleep and when I powered my phone up in the morning, the glitch stopped. The third time is today, I'm currently listening to a hip-hop playlist and this glitch is occurring, it sounds epic, so I'm wondering if anyone knows what causes this or has any consistent way to reproduce this. (((SPOTIFY PLEASE DONT PATCH THIS I THINK ITS A HIDDEN GEM)))

bunmango
Regular

Happens on my Sienna w/ Entunes as well, almost every time I get in the car. Not just with Spotify, but any app using Bluetooth Audio - I've reproduced it with NPR One and Google Maps.

 

Only solution that works is disabling Bluetooth on my iPhone for a few seconds so that it disconnects from the van, and then enabling it and letting it automatically connect again.   Really annoying.

Dkbritton
Newbie
This is Not a solution. The problem is widespread and very alive and unsolved.

Ghostdaddah
Regular
I did cancel my subscription I had for many years because of this. Tired of waiting and it was useless and dangerous to fiddle with in the car while driving. Will likely subscribe again if/when fixed.

gmelissa426
Newbie
This happens to me almost every day when my iPhone connects to the Bluetooth on my Mazda. It happens sporadically too so I can't figure out a workaround. It's very annoying - please help!

Choppyploppy
Newbie
This issue is happening for me a lot lately, using spotify on iPhone with 3 different Bluetooth devices. Tends to happen every time I shut down one Bluetooth device without pausing and then connecting again and pressing play. Listening to EDM at twice the speed is kinda stressful.
Just posting so the devs can see it's still happening

martin_le_kula
Newbie

Same thing still occur for me. Connecting my Iphone 6 to my Volvo and when I turn of the car and leave it with my phone and spotify automatically pausing. Then I return after some time and autoconnects and then it's trippy-gonzalez-speed on the sound and panic is made when turning the volume down and trying to press paus and play or switching song. Is there any fix on the way? Seems like this problem has been happening for several years now.

Ghostdaddah
Regular
Hello!

The «fix» for me was to move the entire household over to Apple Music. The double speed song bug has not reoccurred since then.

bunmango
Regular

What version iOS are you running?  the problem seems to have gone away for me on 10.3.3. The problem I had before was with 10.2.1.

 

edit: never mind, it was a fluke - still happens to me...

SirHaxalot
Regular

First of all, everyone who has this problem, click the Me too button on the first post. Spotify is probably not going to care about an issue that supposedly only affectes 5 people. And don't mark answers that doesn't actually solve the problem as a solution.

 

Second of all, this is still an active issue for me. I have been able to reliably encounter this by attempting to start a playlist via my cars Spotify integration. Basically the flow is that I have sometimes during the day launched another media app on the phone, which has caused Spotify to not be the current media app (reverting back to Apple Music playing "Läser in..."), so obviously bluetooth playback is out. From this point I should be able to connect the phone by USB and launch Spotify from the cars infotainment system. When doing that, playback should ideally resume, it does display the currently playing song, but it's silent. If I from there navigate to library and select a playlist and start playback, I have reliably encountered the double-speed bug.

 

If I unlock the phone, open the app, and then start the playlist, it will work every time. Maybe worth noting is that if I navigate to the app while it's playing silently over bluetooth, the song will still show as playing and the playback time will tick up, just no audio.

 

Spotify 8.4.24.506

iOS 11.0.3

BMW ConnectedDrive

 

Marketymark
Casual Listener

I have had this issue for ages as well.  I've only noticed it with Apple Carplay.  My fix is to unplug the cord and plug the phone back into the car, but that's not always safe to do.  I will try restarting the song to see if that fixes it by I know that advancing to the next song does not.  

user-removed
Not applicable

This had stopped happening for me for a while, but just happened again. Still using an iPhone 6, but on iOS 11.1.2

Banannaise
Newbie

I have this issue in about 25% of cases when I connect to my Audi via Lightning to USB. Happens both with my iPhone 6 on iOS 10 and iPhone X on iOS 11.

SUGGESTED POSTS