Song won't play when pressed

Song won't play when pressed

mrchanadian

Plan

Premium

Country

US

Device

iPhone Xs

Operating System

iOS 12.4

 

My Question or Issue

This morning when I tried to use the spotify app, when I tried to play a song it wouldn't play. The app recognized I pressed it but didn't actually play it. The player above the navigation buttons at the bottom of the screen was also missing. I tried playing songs from my "Discover weekly" and my Liked Songs library and neither worked. I also tried closing the app through multitasking and restarting it and that didn't work either. Restarting the phone didn't work either.

 

I found a solution by playing a song on my PC then changing the device used to play to my phone, but I want to know if there is another way to fix this that doesn't require a second device. Unfortunately I don't have any steps to reproduce since this occured this morning and the app was working fine for me last night.

Reply
21 Replies

Klout

Hi mrchanadian, 

Thanks for posting. 

I know this seems simple but whatever. Anyway do you have a screen protector. If so you might need a new one. 

Hope it helps, (accept as solution)

XKS__Music

Loxer

Hey @mrchanadian, welcome to the Community.

Hope you're doing great!

 

Could you try a quick clean reinstall of the app? Just follow these steps.

 

I'd also recommend updating to iOS 12.4.1

 

Let me know how that goes 🙂

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

battery100

I have been experiencing exactly the same issue on iPhone 7. Reinstallation has not helped. Currently I am on iOS 14.3 and Spotify 8.5.86.739, both have been updating automatically to newer versions. The problem still persists. I'm a Spotify connect user too.

Sometimes I want to play a song, so I go to an artist page, pick one and tap on it but nothing happens. No sound, no player controls at the bottom. However, the songs that won't play can still be played from other places like "Go to radio" or "Liked songs".    I have recorded an example of this bug, where I tapped all the songs under the "Popular" section and none of them started playing.

 

Jeremy

Hey there @battery100,

 

Thank you for your post in this thread.

 

Can you confirm if you performed a clean reinstall of the app? This is different than a quick reinstall and could be helpful to get rid of any cached files that might be causing trouble. 

 

Also - can you log in with another account on the device - such as a friend's or a family member's to see if the issue persist?

 

We'll keep an eye out for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

battery100
Thank you for the reply. Yes, I confirm I did a clean reinstall. I followed the article in Spotify Answers step by step. Today it happened again after I have used Spotify Connect.
Unfortunately I don't have other user accounts at my disposal.

Novy

Hi again @battery100

 

Thanks for keeping us in the loop. 

 

Would you mind letting us know if this is still happening with a different connection? 

 

We'd recommend making sure that your device has enough storage space available and that you're not using any battery saving/task killing apps, as these could cause issues with Spotify's cache. 

 

Keep us posted. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

alcumming

I’ve been having this issue for a couple of years now. Must be aacroas multiple versions of the app and some upgrade cycles of iOS.

The same problem also happens with search occasionally.

I have tried clean reinstall and am sure it’s not connection issues as other apps are working fine every time.

it’s like the request you trigger by tapping just gets lost in translation, though there’s no feedback / errors in the UI to signal what has happened.

Incredibly frustrating 

Alex

Hi there @alcumming,

 

Thanks for the info.

 

If you've been having this issue over a long period of time, there is a great chance that it's related to your account.

 

Can you try creating a new free account and see if it happens on that one as well?

 

Let us know how you get on with this.

 

Cheers 🙂

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

battery100
I have created a new user account with a new premium subscription and since then the glitch hasn't appeared. It's been a few days and everything seems to work fine. It looks like your assumptions were correct.

Novy

Hey @battery100

 

Thanks for keeping us in the loop!

 

We're glad to hear everything has been working properly. 

 

If anything else comes up, we'll be right here.

 

Have a good one.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

askete

I’m having the same issue and have tons of playlists tied to my premium account. If I create a new premium account, how can I ensure I’m not charged double this month, and transfer playlists to the new account? Would this transfer be possibly on Spotify’s end?

Novy

Hi @askete

 

Thanks for reaching out about this. 

 

If you decide to create a new account and subscribe to Premium, we'd recommend cancelling your current subscription following these steps. You can take a look at this article to find out how to transfer your music to the new account.

 

You can also get in touch with our Support team here and they'll be happy to assist you further with your accounts.

 

If you have any other questions, don't hesitate to let us know.

 

Cheers!

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

alcumming

Thanks for the suggestion!

i tried creating a new account and it seemed to fix things... though I’m not keen to ditch my current account. So no many songs, playlists in my collection & artists I follow.

 Any thoughts on how to fix it without losing everything?

Jeremy

Hey there @alcumming,

 

Thank you for your reply and confirmation.

 

You can contact our support team as mentioned above for further help with transfer 🙂

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

zac4390

This is still happening to me and has been happening for years. It has just gotten way worse and more frequent lately. When can we expect a fix from Spotify? I am not spending all that time creating a new account when I have been paying for this account for over 6 years. Please fix or I will find a new music service. 

Novy

Hey there @zac4390

 

Thanks for reaching out about this. Help's here.

 

Would you mind letting us know if you've tried any troubleshooting steps? This will help us give you better suggestions. 

 

We'll be on the lookout.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

sushijean

Hi,

 

This has also ben happening to me a lot recently. it has always happened in the past but it's become worse over the last month or so. It would seem as though the only solution for this is to set up an entirely new account, but the hassle of finding all of my music again is just too much. How would I easily transfer all of the artists I follow/liked songs/playlists/albums?

 

please let me know,

thank you

Jeremy

Hi there @sushijean,

 

Thank you for your post in this thread. We're happy to help.

 

We'd like to start with some troubleshooting first to try to solve this on your current account.

 

Can you let us know what troubleshooting steps you've done so far that's been provided in the thread so that we can help you in the best way?

 

On another note, we see that you mention that you're wondering how you can transfer your music from one account to another one. Here's an article that provides you information regarding this.

 

We'll keep an eye out for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

sushijean
Hi,

I’ve attempted to reinstall the application and I’ve cleared cache from the setting. I’ve logged in and logged out and also tested on another device, but the same problem occurs.

Let me know what I should do next and whether there is a fix for this

Thank you

Suggested posts