Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Autoplay not working in 2021

Autoplay not working in 2021

 

Plan

Premium

Country

Croatia

Device

Samsung Galaxy S20+

Operating System

Android 11

 

My Question or Issue

Autoplay is not working from search. When I search for a song and the selected song finishes, nothing plays after it, the song radio does not start to play automatically. Pressing the forward button also does nothing but restart the searched song. I have the latest app version, I have performed a clean reinstall as per instructions here, I have given all permissions to the Spotify app, as well as exempted it from all battery saving and optimization. All in all, I have tried every solution offered on the forums, but nothing seems to work. This issue persists on other phones, but not on Windows. Members of my family also have this issue.

Reply
35 Replies

Same issue happening since I updated Spotify last week - I've tried everything in this thread with no luck.  Premium Family Subscriber and would very much like to see this corrected.  iPhone 8 iOS 14.8 10/29/21

Hi there @dsecouler,

 

Thank you for your reply in this thread and for the troubleshooting you've done so far!

 

Can you have someone log in with their account on your device to see if the issue persists? This will help us understand if it's account related or not.

 

We'll keep an eye out for your reply.


Take care 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Same issue but I managed to make it work. I did what GoofyB said but instead of enabling the 3 of them I disabled them. And it did work the auto play.

Hi! I have the same problem too! I have worked with Google support and they don't seem to find the problem. Its been 2 weeks like that. My push notifications are enabled for Spotify. 

 

Its when connected with Google Nest Audio.     

With Google Pixel 4a and Android 11

I'm a premium Spotify user, by the way. 

 

 

Exactly the same problem. Really frustrating.

I've tried all the suggestions and nothing worked.

Randomly, about a week ago, autoplay worked after one request.

The problem happens regardless of how I access music - voice request to google nest audio, playing a song on my phone or casting from my phone to google nest or my car's bluetooth.

It also makes no difference whether I request a single track, an album, a playlist or an artist - once it's finished the music stops.

This apears to be a persistent issue for many users going back quite some time. I have wasted hours this week trying to reslove the problem. A solution from spotify for your paying customers would be appropriate.

Yep, the same issue too, but even not just in my Phone also in my PC:/

Hi folks,

 

Thank you for reaching out.

 

In the last weeks there have been changes made to the AutoPlay feature, where it was automatically set to on/off in devices such as Google Nest, Echos, TVs, wearables, etc. 

 

However, from the desktop PC now you should be able to toggle on/off AutoPlay in external devices from the desktop app.

 

image.png

 

@RicardoGarcia In order to better assist you, could you confirm if your issue with AutoPlay is when your music is playing on your phone/PC, or when playing it on an external device? 

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

It is when I'm playing on my phone/PC, I checked that new feature and toggle it on-off but the issue continues

Sometimes, depending on the content, there might not be enough data available for related songs to generate an Autoplay queue. We suggest to try starting a radio station from the track instead. If successful, the radio will include said song as a first one and similar ones.

 

Do note that even if the app can generate a radio, it might be a finite playlist and Autoplay from it can again be unavailable.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I have tried everything on this thread. From the notifications, to the clean reinstall and everything in between and autoplay is still not working. The only place it works is on the chrome web player. But on the computer app and my iphone it does not work. It is very frustrating because this feature is one of the main reasons I switched from Apple Music. If you can't get this little issue fixed then I will have to jump ship. 

I had this problem on my desktop mac. Tried everything you suggest. The fix for me was to turn off the wifi on my computer... 

Hey folks,

 

Thanks for posting here.

 

Justo to double-check-are any changes when you log in to another account?
 

If that doesn't make a difference, could you share with us the following? We'll look into this further.

  • Device + OS version
  • Exact Spotify version

Keep us posted.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

iMac (Retina 5K, 27-inch, Late 2015)

3,3 GHz Firekjerners Intel Core i5

24 GB 1867 MHz DDR3

AMD Radeon R9 M395 2 GB

mac os: 12.0.1 (21A559)

 

Was not able to copy from the spotify app so i attached a screenshot of version

Skjermbilde 2021-12-20 kl. 11.45.12.png

Hi @JT69,

 

Thank you for sharing that information with us. 

 

Just to make sure, did you get to test this with a different account as @Ver suggested? 

 

This will help us narrow this down and determine if this is an account related issue.

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I have no other user to test it with. But I tried everything else. very strange though, cos I have had the wifi on forever, so its obviously somethhing that has happened through an update.

Hi @JT69,

 

Thank you for keeping in touch.

 

Could you confirm if this issue happens only on your Mac computer, or also on other devices? 

 

Also, we'd like to clarify if the issue you're presenting is that the AutoPlay feature can't be activated/deactivated. 

 

We'll be on the lookout.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts