Help Wizard

Step 1

NEXT STEP

Podcast Won't Play

Podcast Won't Play

 

Plan

Free

Country

USA

Device

Multiple

Operating System

Multiple

 

My Question or Issue

A podcast I have been listening to for months, Behind the Bastards, suddenly won't play on any device.  I've tried both the web player and app on two different Windows 10 computers and on my Android phone (Samsung Note 9).  The progress bar shows up as if the podcast is playing (shows the episode title and "Play" button turns to "Pause" button as if playing), but it never actually plays.  I've tried multiple different episodes.  Other podcasts and music play just fine, but I suddenly can't keep listening to this podcast that has become a big part of my office routine at all.  Extremely frustrating.  Does anyone have any idea how to fix this issue?  I have seen a couple old posts with similar problems, but no solutions on any of them, and the latest one was nearly a year old.  Thank you.

Reply
66 Replies

Hey @BexStJohn,

 

Sorry to see you've been experiencing this issue...
The episode does open & play from our end. Have you tried with another network and does it maybe open from the Web Player :?
This will help us narrow down the reason why this is happening.
Thanks a lot!

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I also have been experiencing this issue with radiolab podcasts. Only that podcast won’t play, yesterday other podcasts and undownloaded songs would not play despite my high download speed . But today all the others are playing and I am having trouble both downloading and playing radiolab episodes. I tried deleting the app and redownloading, and trying on different wifi. Nothing seems to work, and I do have premium.

I am also having the same issue, it started last night. I was listening to The Last Podcast On The Left, had been for hours at that point. It ended one episode and then silence. I look in Spotify and it shows episode 95 is trying to play, play button is a pause button, it shows the length of the podcast but there’s no podcast playing. It’s happening on both my laptop and iPhone. Other podcasts are having issues playing too. Husband opened the same podcast on his desktop computer and he couldn’t get it to play either. Did a clean re-install twice, tried playing from web player, logged out and logged back in again, tried any other episode I haven’t listened to yet (all episodes that I’ve already listened to work) tried downloading (it won’t download). I’ve been a premium user for years. Again, this issue is happening on my iPhone, my Windows laptop, and my husband’s Windows PC. 

Hey there @Epolsky and @Xyre,


Sorry to see you've been experiencing issues with podcasts.

If you haven't already, here are a couple of things you can further try out:

  • Use an incognito / private window. On some devices it's called Secret Mode. You should find this option in your browser's menu.
  • Clear your browser's saved cache and data and try again.
  • Use a different browser. For example, if you normally use Google Chrome, try with Microsoft Edge.
  • Try changing your network. If you use Wi-Fi, try switching to mobile data instead.
  • Turn off any VPN services ( if you're using one)

Let us know if that helps. If not, please return with links to the podcasts in question, so we can take a closer look and advise you better 🙂

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

All,

 

I am having a similar issue and cannot play any Podcasts.  Again, as the earlier user, I have the play button available and can listen to other music songs, but when I click play on any Podcast nothing happens.  This is the same if I try via mobile device (iPhone 13) or my PC thru a web browser.  Does anyone have any ideas on what is happening?

Hey @prmorrone,


Welcome to the Community and thank you for joining the conversation.

 

If you’ve tried all the troubleshooting mentioned in this thread and the issue is still persistent, it could be related to an Ongoing Issue that we’ve currently Under Investigation by the internal teams. We hope to get it resolved as soon as possible. Feel free to add your vote by hitting the “Thumbs up” button and subscribing to this thread to be aware of any updates. We appreciate your patience and understanding.

 

If you have any additional questions, don't hesitate to ask.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

All - Typically when you go to cast you have options if you click on the "..." for either "Spotify Connect" or "Google Cast". This works well with all music; however, for Podcasts, there is no option for "Spotify Connect" and that seems to be the real issue.  As such, it seems to be a Spotify issue as they block the use of Spotify cast on all Podcasts.  Not sure why.

 

Examples below.  In the third shot, you have all options and can select the "..." for the type of cast or to forget the device.  The first is if you are playing a Podcast.  The second shot shows you the options after you select the "...".

 

In the first shot you can see, there is no manner to select any options.  The "..." don't even appear.  So this is not a third party device issue, it is the optionality offered or not by Spotify.

1)

IMG_1248.png

2)  

IMG_1247.png

3)

IMG_1249.png

  

Suggested posts