Announcements

Some items in the Browse menu are broken

Solved!

Some items in the Browse menu are broken

polozhitelen

Plan

Premium

Country

Bulgaria

 

Why do these 3 items in the Browse menu appear like this and also do not work?

 

1.png

 

They look and act the same way on the web player and the desktop app (Windows 7)

 

2.png

 

As you see, they don't show a playlist cover in the box like the other categories.

 

When I try to open one of these 3 categories on the desktop app, they open an internal link in the browser:

https://xpui.app.spotify.com/index.html# 

and it doesn't load, saying it can't be reached.

 

And when I try to open them on the web player, they open a new tab to the search page and add # to the url, again, not opening the category.

 

On my phone (Android 10) they work fine.

 

Reply

Accepted Solutions
Marked as solution

Yordan

Hi @polozhitelen,

 

Thanks for reaching out to the Community.

 

Could you let us know the version of your Spotify app? You can find it under the three dots in the upper left corner > Help > About Spotify.

 

Feel free to also share what troubleshooting steps you've tried so far so we avoid repeating them. If you haven't already, try deleting the prefs file under C:\Users\%username%\AppData\Roaming\Spotify, as well as the contents of the Users folder. found in the same directory, then restart the app.

 

If that doesn't work, try performing a clean reinstall by following the steps here.

 

Keep us posted on this.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

View solution in original post

3 Replies
Marked as solution

Yordan

Hi @polozhitelen,

 

Thanks for reaching out to the Community.

 

Could you let us know the version of your Spotify app? You can find it under the three dots in the upper left corner > Help > About Spotify.

 

Feel free to also share what troubleshooting steps you've tried so far so we avoid repeating them. If you haven't already, try deleting the prefs file under C:\Users\%username%\AppData\Roaming\Spotify, as well as the contents of the Users folder. found in the same directory, then restart the app.

 

If that doesn't work, try performing a clean reinstall by following the steps here.

 

Keep us posted on this.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

polozhitelen

Thank you for the reply! ;))

 

I didn't really get to try any of the solution methods you mentioned because the problem "resolved itself".

 

I suspect it was some sort of a caching problem and/or the items lead to a dead link or there was some other minor bug. Whatever the reason, everything works fine now - I also checked on my other device (Windows 10).

 

It wasn't a really big inconvenience for me but I know how some little details in the code may be overlooked and cause problems so I decided to report it anyways.

 

Thank you and have a nice day!

 

Cheers!

Eni

Hey @polozhitelen,

 

We're glad to hear that now it's working as expected. Give us a shout if it starts misbehaving again; we're always here to help. 

 

Have a great day 🙂

 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Suggested posts

Env: prod