Announcements

Help Wizard

Step 1

NEXT STEP

Nothing is playing

Solved!

Nothing is playing

All playlists are empty or just silent or require premium. Only shorts do some noize but like anything except it doesn't work. I tried reinstallation, it didn't help
Reply

Accepted Solutions
Marked as solution

Hey there, 

 

Thanks for reaching out here in the Community.

 

It sounds like you might have been abroad for more than 14 days. Keep in mind that you can use a free Spotify account in a different country or region than where your account is registered for up to 14 days. After that, you won’t be able to play anything. 

 

We'd recommend making sure to update your country in your account settings by following these steps. You can also subscribe to Premium to continue using your account.

 

Hope this sheds some light on the situation. If anything else comes up, the Community will be here.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

View solution in original post

15 Replies
Marked as solution

Hey there, 

 

Thanks for reaching out here in the Community.

 

It sounds like you might have been abroad for more than 14 days. Keep in mind that you can use a free Spotify account in a different country or region than where your account is registered for up to 14 days. After that, you won’t be able to play anything. 

 

We'd recommend making sure to update your country in your account settings by following these steps. You can also subscribe to Premium to continue using your account.

 

Hope this sheds some light on the situation. If anything else comes up, the Community will be here.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I opened spotify today and I can't open anything. My liked songs Playlist is fully empty but shows the number of liked songs. And whenever I click on a Playlist to play it says "you've discovered a premium feature!".
Please I need help

Hey @Jenny1278,

Thanks for reaching out and welcome to the Community!

Just to confirm, does this happen with all playlists? Or just when you're trying to play Liked Songs?

 

Does it appear in the same way on another mobile device? For example, you can log in to your Spotify account on a friend or a family member's device.

 

Feel free to include a video or screenshot showing how things look from your end as well. This will help us get a better understanding of what's happening.

 

Keep us posted!

MariaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Spotify podcats and playlist are ahowing that there are no episodes for podcast or no songs in this playlist. I have tried reinstalling it and also changing the account but nothing seems useful

Hey there @noname99,

Thanks for posting on the Community!

Just to check, does the playlist appear in the same way on other devices that you use Spotify on? Also, is it only one specific playlist that appears empty, or does it happen with multiple playlists?

Should things look alright with the playlist(s) on another device, please check if you're using an SD card on the device you're experiencing issues with. If so, try removing the SD card to see if you notice any difference.

 

A screenshot or video showing how things look from your end, should the issue persist, would be very helpful. If the files are too large to attach here in the Community, you can send them to us via Google Drive or as unlisted YouTube videos.
 

Let us know how you get on!

MariaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Yes it happens with all playlists and both of my devices

Screenshot_20240410_175602_Spotify.jpg

Screenshot_20240410_175620_Spotify.jpg

Hello !

I'm having the exact same issue 😕 (and I'm also using free Spotify)

Everything was working fine until a few days ago.

Now I can't play any songs on my phone.

It does seem to work on my computer though. 

The same thing happens to me only on my Android. On the computer or on the web it works fine, but on my phone all playlist and podcasts appear empty regardless if it was created by me, spotify or someone else. And I also can't listen to anything, even when I try to listen in the random mode, it says I am trying to use a premium feature.

Hey there @daniruas,

 

Thanks for joining the thread!

I have a feeling that you've logged in with a different account on your mobile device. 
It would explain both the Premium prompt and the empty library.

To check if this is the case - take a look at your Spotify app on another platform where you're already logged in.
Your account settings should be accessible via the app settings.

Should you need any further help with this - take a look at our FAQ for additional steps on how to locate a secondary Spotify account.

We'll be here for you in case there's anything else 🙂 
Cheers!

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Plan

Free/Premium

 

Device

(pixel 4a , )

Operating System

( Android Oreo,.)

 

My Question or Issue

hello, here's a weird issue i'm facing, i can't play any of the songs on this account. i can't see any playlists, songs just refuse to play. i tried another account, and it works fine. logging in to another account on android app or using web works fine and plays music.i tried reinstalling the app, clearing cache, nothing seems to work

Thank you so much. It would be helpful to receive some sort of popup or warning to understand what's happening. Receiving no feedback is disappointing.

Hi @legates,

 

Thanks for the reply. Could you confirm the specifics of the behaviour:

  1. The playback doesn't work only with your account on a specific device? 
  2. The same account works on other device?
  3. The affected device works with a different account?

Please let us know and send us some screenshots of the exact error you get and we'd be happy to investigate further.

 

Keep us posted.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Joan, the issue was isolated to one account. It turns out the problem stemmed from not being in the country I had selected on Spotify. However, I was completely unaware because there were no notifications or messages to inform me. Previously, it would log me out, but this time I had no indication of what was happening.

Hi @legates,

 

Thanks for the reply. We're glad you found some clarity on the matter. Has the playback issue been resolved or do you still face some issues? Let us know and provide us some details on the behaviour so we can assist you further.

 

Keep us posted.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Yes Joan, everything is functioning as expected. For future reference, I would appreciate a notification explaining the nature of the problem.

Suggested posts