Help Wizard

Step 1


Interesting bug on iPhone lockscreen


Interesting bug on iPhone lockscreen

Hello everyone,

I've recently updated to Spotify 0.5.2 and noticed that the iPhone Spotify app is causing an issue on the iPhone lockscreen in regards to displaying the currently playing track name. When I begin to play the first song of an album, it plays correctly. If I then try to skip to the second track through the lockscreen, it also works correctly and the song name under the clock is updated correctly. However if I try to skip again to the third track, the third track begins to play but the second track's name still displays under the clock. I can skip forward and back at will from the lockscreen, but the second track's name will always be displayed. I thought this was iOS6's fault, but then I tested it on an iPod Touch 4G running 5.1.1 and got the same issue, which leads me to believe it was a Spotify bug. I then used iTunes to revert back to 0.5.1 on my iPhone running iOS6 and the issue has gone, further underlining the fact that (for me at least) it has been a bug introduced in 0.5.2. Can anyone replicate this bug? I'd like to see if a patch could be issued so I can get the new Radio feature without losing the ability to see my song name in the lockscreen.

126 Replies


We're still looking into this lockscreen issue. As soon as we have an update, we'll shout it from the rooftops.

Airhorn Enthusiast



Thanks much!




I just noticed that you can still download an older version of Spotify on the app store, called "Spotify for iOS 4". I'm using it, and it doesn't have the problem (I'm running iOS 5.1.1 on my iPhone 4). At least this is some kind of temporary pacification until they fix the issue in the current version of the app.

Hey David. Thanks for posting to let us know we're not being ignored. The problem is I paid $9.99 twice and haven't used it much because I've been using Rhapsody instead. I'm not sure I want to pay again and have this problem persist for another month.



Suspend your Spotify account so it's not charging you, but keep the app on your phone so you'll be notified of updates. When one is released with a fix to this problem, just reactivate your paid account.





All, I tried what danielthelion mentioned and downloaded the app named "Spotify For iOS4". Even though, I am iOS 5, it works! Track names and times change while locked. 🙂 Very nice!

Did you delete the current app or are you running them both? Thanks.

I now have both side by side. Did nothing but install Spotify for iOS 4 and logged in. Chose NO on "Upgrade because we detected you're running iOS5?(paraphrase)". Also, modifed my quality settings to High in options.

Times up Spotify. 2 months and no fix for a simple bug. Thats pathetic. Cancelling my service right NOW.

My Spotify acct. expires today so I guess this is my last post here. I am now a Mog user and it is hands down better than Spotify. Thank you Spotify for not fixing your app so I could discover the wonderfull Mog service.

Just installed update 0.5.5. Still no fix. Unbelievable!

@Marko_K wrote:
Just installed update 0.5.5. Still no fix. Unbelievable!

99% of the updates are useless. Welcome to the team!

Weird, it was working in the new version on my iPad last night, but it is definitely not working with my iPhone this morning.


I don't really understand why this is so hard to fix?

Wow, so 3 releases over 3 months and still broken. Comically bad treatment.

I'm amazed by the Spotify developers who is ignoring this (and others) annoying problem.


Before you add new features maybe you should get rid of the the most problematic bugs that is

destroying this great App.


I'm using this App 1-2 hours per day, and it's crashing at least 2 times per day.


If you could fix these two bugs, you will have time to make new features in peace.

And also test the new versions thoroughly before releasing them.


You are losing customers by ignoring these problems => less money for you => unemployed


If I where the developer manager I would take care of this ASAP.


And stop saying "Try a clean installation" and "Restart the Iphone".

You know that's not the problem, you just want to buy time. You can do it one time, after that you

have to say as it is. Admit that you are having problems with the App.


Also think about giving the users some compensation for the crashing problems .


To have good customer relations is the key to a long and successful business.

If I had to listen to on of these morons tell me "try a clean install" , "Restart your device " one more time I think I would have thrown up. I'm telling you people. Try the Mog service. So much better in every way. And no I don't work for them.

Thanks bigdrop, going to try them tomorrow.

This crap is why I left Android. You developers focus on new features before fixing obvious production issues. IDK how your dev team works but I can assure you that this nonsense wouldn't fly with any team I've been on. I've waited months for this stupid bug (and others) which should be high priority to be fixed. This is the last straw. Good by Spotify. I'm switching to Rdio and I'll make sure to let everyone I know that you're service is lackluster at best. Rdio may not have every feature Spotify does but their app is solid and they don't drive on Facebook.

Version 0.5.6 came out today. And guess what? No fix. STILL NO FIX! Same problem still exists with both iPhone and iPad. 😞

It blows my mind a little bit that such a standard feature hasn't been fixed yet over a few months.

The bug isn't showstopping, but we shouldn't have to be complaining about this.  I've never ran into an audio app on iOS that has exhibited this problem.

My general sentiment of Spotify and the company itself has changed dramatically over the past few months. Before this issue I would rave about the service. Now, I have a lukewarm attitude at best when someone asks me how much I like it. It's hard to be excited about it anymore when I'm being disrespected("Try it now, did the new version fix it?" -- Waste my time) and lied to("We've got our best guys working on it, promise!") about this "little" bug being fixed since June!!

Suggested posts