Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Local files wont appear on Iphone

Local files wont appear on Iphone


Premium Student




Iphone XS

Operating System

IOS 13.3


My Question or Issue

Ive enabled local files on spotify on my computer. Ive added them to a playlist. Im on the same local internet.I have also tried connecting to my phones hotspot. i can play the song on my computer and it will play on my iPhone. However none of the songs will show up in the playlist on my phone. The farthest Ive gotten is getting this message. The issue is there's no offline sync anywhere in my spotifuggle app on my computer both from the Microsoft store or downloaded from spotifys website.

Spotify image.png
53 Replies

Thanks. I have already started using DropBox to hear my music files. I did a router restart as well today but to no avail with Spotify. I will raise a support ticket as advised.

Seriously why is it so hard to have my music in one place? Whats the point in me paying for spotify if a simple option likle uploading my own files is so difficult? It's embarassing. 

I have tried every method posted on here to get my local files to play on my iPhone. I have cleared the cache on both my phone and laptop 3 times as you suggested but I still am not able to play the songs downloaded onto my phone. I even updated my phone and laptop to the most current software. I'm definitely getting pretty frustrated by this. Please help ASAP!!!

Hey everyone,


Thanks for reaching out to us.


To everyone experiencing issues with their local files that have tried the steps here and here, we recommend to make sure that Synch from Desktop is enabled. This option can be found under Settings> Local files.


Afterwards move the files on your computer to another folder and set it as local files source on your desktop. Delete the playlist on both your smartphone and desktop and create a new one with your tunes. Instructions on how to do these steps can be found  here.


Hope you find this useful. Let us know how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Found a fix!

There is a new menu in the settings to sync local files to the device you are using. Hope this helps!


This was a while ago but this solution worked for me! Thanks Peter 🙂 

Hey @Micronomics!


We're happy to hear that everything is working just fine. 


If you have any other questions, don't hesitate to reach out to us.


Have a good one 🙂 

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself! 

I had this problem for *ages* - weirdly, it would download on my Android - but it would work "occasionally" on iOS, then stop. I tried deleting the cache, deleting the app over and over, but finally I stumbled upon the 3 things I needed to do to get it to work.

1. In iOS under "Home>Settings (cog in upper right hand corner)> Local Files - make sure it's turned "On" (green).

2. This is the weirdest part: I read somewhere that Netgear routers and Spotify don't get along, so I set up an adhoc wifi hotspot using my mobile phone and joined my iOS to it. (as a side note, iOS would NOT connect to a 5GHz network, so I had to set the phone wifi hotspot into 2GHz/compatibility mode)

3. Make sure your PC and your iOS device are connected to the same wireless hotspot.

I did the above and it worked *immediately*

So the problem doesn't appear to be Spotify, but Apple.


Allow Spotify in this menu.


This was the only answer helped me! Thanks!

Hi there @xAmbition, @kokot1 and @user-removed,


Thank you for your replies in this thread.


@xAmbition and @kokot1 - it's really nice of you to share what worked for you. Thanks!


@user-removed - We're really glad to hear that everything works as it should for you again.


Let us know if we can help you with anything else 🙂

Take care!

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Stop Emailing Me

I found the answer! It's in the settings - you have to toggle on local files. I couldn't figure this out for the longest!

I found a way that has worked for me. So I opened the Spotify app on my phone and PC and you play the song on your PC. Then you are able to like and add the song to a playlist. 



Suggested posts