Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Headset Play/Pause/Skip - Forward/Backward NOT WORKING

Headset Play/Pause/Skip - Forward/Backward NOT WORKING






OnePlus 3T

Operating System

Android 8.0


My Question or Issue

Approximately 1-2 weeks ago, controls on my Bluetooth headset stopped working, volume up/down works, but Play, Pause, and Skip does not work anymore.


Logging out of Spotify and loggin in again solves this isue partily.

One of the action above will work, but only for one time.


Log out, login, skip one song (or pause/play), couple of seconds later the app crashes....



Searching the forum just shows me that this is a repeating bug, please make it a Working function!



5 Replies

Hi Mixria,

Thanks for getting in touch with the community.


I know I experienced this headset behavior a couple of years ago. After a bunch of research, I came to the conclusion that it wasn't within Spotify the problem laid, but in either the headphones or the headphone software.

Have you tried the controls with another set of headphones? Have you installed any other app recently, that might be using the headset controls as well, making them not responding? I imagine, if you have an app open at the same time as Spotify and trying the controls, it might get "confused". Just a theory.

Try installing any kind of headset controller from Google Play and see if it helps.

This one seems popular: Smart Key


All the best,


Thanks for you're reply and suggestions👍

I'll try that as temporary solution.


New and ekstra info:


I've had this headset for over a year without any troubles, until now.

Don't have another pair, but I'll try a buddy's when possible to rule out ethier one.


When I testet it yesterday, I had only Spotify running.


And while writing just now, I found that Android gestures didn't work either.. one minute ago...

And now both works.. gestures and headset...

(Have done nothing, no reboot or anything)


Haven't installed any apps recently, as I remember.

At least not anyone that hasn't been uninstalled too if so.



Around 4-5 moths ago I made a complete reinstall of Android and there hasn't been any OS updates in that period..


Thanks to anyone who looks at this post 👍



What I've read in other topics and posts it usually is the headphones/earphones themselves that might be acting out. So yeah, try another pair and see if it works!


By the sound of it, if Android Gestures also shows weird behavior it might be the phone - as in a software glitch of some kind. Try turning the "Waze navigation" off in Spotify settings. It might be picking up sound from your surroundings or just hogging the controls. Just a guess, as I remember that strong winds or high noise could temporarily lower the volume and/or control the playback via the microphone on the headset. Might be a completely different fix, but worth trying!


Also, I found the app which I initially tried to find, which worked well for me a couple of years ago: JAYS Headset Control


Good luck! Just post here when you've done some troubleshooting!


One of the reasons this might happen on Android phones is Google Assistant overrides earphone button events.


I'd suggest to search in Android Settings: "devices"



From coming results what you want to select is Google Assistant Devices



In the next screen select your device



Top option: "Get help from Google" is where you enable / disable interaction of your device (earphone) with Google Assistant. Disabling it would probably fix your problem




Suggested posts